AnsweredAssumed Answered

Modifying Save Bodies Command Results In "Unable To Find..." Error

Question asked by Mitchell Sherry on Jul 18, 2019

Greetings Fellow Solidworks Users,

 

Every now and then my team is encountering an issue with the "Save Bodies" command that is causing time loss and I can't come up with a reasonable explanation or solution. 

 

I am hoping that someone may be able to provide some insight.

 

For certain furniture product lines we work with a base model and then use a set of "Save Bodies" commands to save out each casegood or frame element for the product line. Throughout the development process we often have to make changes to the individual parts, so we roll back before the particular "Save Bodies" command, make the changes, roll to the end of the feature tree, open and re-execute the particular parts existing "Save Bodies" command, and the changes propagate through to the existing "Split Parts & Assembly." Rather simple process that works 95% of the time. 

 

Now, for reasons unbeknownst to me, on occasion when following the same process as outlined above, the error message that I have attached a screenshot of will pop up "Unable to locate the file ***original file path***. Would you like to find it yourself?". 

 

I understand how SW file hierarchy works regarding re-naming / moving files and the like, however; in the instances of this happening, nothing has been moved, renamed, or changed in any way whatsoever. 

 

Furthermore, if we go through the process of "finding" each split body per the dialog boxes option, you do get the correct result of the changes propagating through to the split bodies & assembly, but right away if you edit the same split body feature again... the same error dialog box pops up and we have to "find" each file again. 

 

I have checked the external references of the split bodies via SW Explorer and everything is in context and referenced to the correct base assembly SW file and vice versa. We also tried both having referenced documents being opened when changed and not being opened in the system preferences for the base assembly and subsequent split parts. 

 

Does anyone have a similar experience or perhaps some advice on how to circumvent this error? Anything besides changing the overall modeling approach to not include the use of base assemblies and split bodies, as this has been a huge success for our team until this troublesome error started costing us tons of click time. 

 

Thank you, 

Mitch 

 

savebodies solidworks error cannot find file

Attachments

Outcomes