AnsweredAssumed Answered

Solidworks PDM Standard - Missing files

Question asked by George Maddever on Jun 28, 2019
Latest reply on Jul 1, 2019 by Jim Sculley

Hello all. I've got a very vexing problem, and I'm completely stumped!

 

We're running SolidWorks PDM standard 2016 and a large number of files (300 or so, parts, drawings and assemblies) have gone missing.

 

First I heard of it was when one of my engineers came to me and said he was having trouble with a part that he couldn't check in or out. Turns out the file was a greyed-out <local file>.

 

Usually this means that a file was moved or deleted or something and it's not a hard thing to rectify, but looking at it on my admin workstation, I could see that this was not a single file, it was a large number of files in my local PDM folder were now showing as <local file>. These are all files that have previously been in the PDM system and working as normal.

 

This was replicated across all of our workstations, all of them reporting the same files that used to be on the PDM server were now only local files. This means we no longer had access to a large number of files on this project. The issue seems localised to just this one folder, which is currently being worked on by several people.

 

Right-clicking and trying to add these files back into the vault brings up the error message that the file already exists.

 

I've gone through the regular troubleshooting of checking that file visibility is on, tried viewing as the admin etc and it appears that the files are just gone. I've looked through the logs and they haven't been deleted and there's nothing I can see in the activity logs that stands out as being odd. Searching the vault doesn't turn up the missing files anywhere either so it's not like they've been moved either.

 

Of course our files haven't actually been lost as we still have the local copies (although we will have lost any previous versions/revisions of these files). The only thing I can see to do is to move the remaining files into a new folder on the vault and then merge in the missing local copies.... either that or restore a backup from a few days ago of the entire vault, neither of which is 100% ideal.

 

I've tried to think of how this has happened, but the files that have gone missing don't all belong to one part of the design (not limited to one subassembly/assembly), and I can't think of how I'd even go about replicating this if I was trying to do it intentionally.

 

Can anyone suggest anything I might have missed? Is there anything else I should check? I've been a PDM user for about five years and this is the first time I've had anything like this and I've spent the whole day so far trying to work out what the heck has happened!

Outcomes