AnsweredAssumed Answered

3D PDF & 3Dconnexion SpaceMouse no longer work together; what changed?

Question asked by Tom Gagnon on May 7, 2019
Latest reply on May 17, 2019 by Tom Gagnon

I fully realize that this forum does not control Adobe Reader, nor 3Dconnexion SpaceMouse products. However, it is active, and some of us do use these products. As such, I am seeking peer user experiences, not some official response. I am working towards finding a solution. For now I am gathering info before asking a question on 3Dc or Adobe forums. It appears that they pass the blame to each other anyway and let users post real solutions. (Undated entries in the 3Dc FAQ 'Knowledge Base' do not help in providing wider context to my problem, either.)

 

We've been using 3D PDF's to communicate full interactive assemblies to our Shop workers for a few years now, because it runs on minimal hardware which is not a workstation, and because eDrawings sucks terribly at viewing the same large things in the same way. This has been so effective that we purchased a SpaceMouse for our shop manager to ease navigation of 3D PDF's in Adobe Reader DC. This worked great. Now it does not.

In Adobe Reader DC and also in Adobe Acrobat X Pro, today the SpaceMouse inputs do nothing at all. This has happened recently. It was working as before as recently as two weeks ago. Same thing now applies on multiple PC's with the two different Adobe apps listed above. What changed?

 

I searched support forums of both 3Dconnexion and Adobe for help. Some topics relating to similar issues date back to 2010, another in 2015, and a little bit as late as September 2018. One suggested disabling protected mode application sandboxing, which is inadvisable and did not in itself work anyway. One suggested replacing an API file within Reader's Program Files with the same file from an older installation, which also did not work. One suggested solving it through complicated group policy edits across the organization.

 

First thing that I tried was just to update the SpaceMouse driver (last updated April 2019, iirc). This improved nothing. Otherwise I wouldn't still be looking.

 

Is anyone else here: 1) using a SpaceMouse, 2) already have 3D PDF's to test, 3) it used to work, and 4) now it doesn't?

Or, did you already experience this and fix it and know what I ought to do about it? Thanks for any feedback. If I find something useful, I'll link it here.

Outcomes