AnsweredAssumed Answered

Design Checker not loading changed checks and proliferating files

Question asked by Thomas James on Apr 27, 2019
Latest reply on Jan 7, 2021 by Johan Visagie

I've been configuring Design Checker for my office, and have run into some strange and frustrating behavior. We use PDM Pro, and all files for Design Checker reside in PDM Pro, checked in under the Administrator account.


Short version: Design Checker isn't using the new version of a standards file after I make changes to it; this led me to notice a bizarre proliferation of files related to Design Checker runs.


First, when I make changes to the check standards file, they don't take effect when I run Design Checker again. Design Checker runs the original checks instead. It doesn't appear to make a difference whether I exit SolidWorks and restart it, remove the standards file from the Design Checker "Standard Files" list and re-add it, check out and check in the standards file in PDM Pro, clear the PDM Pro cache. The only way I can consistently get the changes to take is if I save the standards file under a new name, which just starts the whole thing over again. Bizarrely, I logged out of PDM Pro, cleared the cache, deleted every other copy (more on that later) of the standards file I could find on my local machine, and ran Design Checker again - and it ran without protest, with the same result (ignoring the changes).


Which gets us to the proliferation of files.


Every time I run Design Checker a new set of folders and files appears under ...\Validator in this path, using different numeric names but the same folder structure:

C:\Users\[my userid]\AppData\Local\Temp\DesignChecker\2018\Validator\190426225702626\190426225702628\Merge


There are sometimes additional subfolders at different levels in the path, containing another copy of the standards file but with the name truncated.


When I close SolidWorks, and delete the entire path from \DesignChecker down, then reopen SW and try to run the same check again, it does the same thing all over again, checking against the outdated (and deleted) standards and recreating the path/structure shown above, complete with resurrected copies of the deleted standards file.


I've searched the entire local machine for additional copies of the standards file that Design Checker might be drawing from, but can't find any (which is inconclusive, since the copies in the ...\Validator folders don't turn up in a search either).


I'm at wit's end with this problem. I suspect that the file proliferation and the failure to see the changes in the standards file are related, but I can't find any other reports of this problem and I don't see any settings that would appear to be causing it.


Any ideas on how to address this? I'm not worried so much about the file proliferation, so long as I can just get Design Check to use my updated standards file.