AnsweredAssumed Answered

PDM is NOT compatible with Simulation?

Question asked by Ken Lux on Mar 27, 2019
Latest reply on Mar 29, 2019 by Solidworks Swcare

SW 2017 SP 5.0

 

For the love of all that is precious in this world, why can't SW make their own packages compatible with each other?

 

So I had a part with some simulations completed in our Workgroup PDM vault. I updated as assembly that contains that part outside of PDM during our transition from Workgroup PDM to PDM. Then when I went to check in the assembly - BOOM - cyclic reference with absolutely zero guidance on how to resolve it anywhere in the known universe.

 

I also saw that half of my studies on the unchanged part were all messed up. For some things were normal - results tree normal, I could show the results. For some the results tree looked normal, but when I tried to show the results I got the error "Database not found". For some, the results tree was grayed out, but I could show the results.

 

I manually checked out all of the simulation cwr files from the vault. Then I set the location of the files in each study to the vault folder with these files in it. Some of the problems got fixed, but some didn't. Then I just deleted the studies that still had problems. Now cyclic references were gone. And I can check in the part.

 

So at this point it appears that PDM says there is a "Cyclic" reference if there is a problem locating the results file.

 

So I had to throw away a few days of work, but I attributed it to the vault transition.

 

Everything is OK now, right? Wrong.

 

So I re-run a simulation and after letting it run overnight, I get some decent results. But now, whenever I save the part, I would get a message that "Simulation cannot create temporary file in the directory c:\users\<USER>\appdata\local\temp. Check if your working directory has write permission for you." I note that this appears to be the default location for the simulation results if you do not use the SW document folder. But I am using the SW document folder, which in this case is a folder in the vault. Plus I have full access to all folders as I am an admin on this machine. So even if it was trying to write files to the wrong folder, I have write access to that folder.

 

I searched online for info and the only thing I found that seemed relevant was that simulation (not flow simulation) is trying to use that folder for temporary files for generating results plots. Lo and behold, when creating a report, that folder is used to store temporary files.

 

OK, odd and buggy, but that's what I have come to expect with SW post 2014 version. I see the CWR file in the vault with a modified date from the time the simulation finished, so everything is groovy. All I need to do to get on with my life is check the part back in. And then there you go! I can't check it in because there is a cyclic reference in the part and the CWR file again!!!!!!!! The part has no external references either.

 

 

I tried going offline and back online again. Same thing.

 

I went to the simulation study tree, RMB on the top level of the study->Options and set the Results Folder to a folder outside the vault to see if that would help. It asked me if I wanted to copy the results. I said yes, and it copied the CWR file to the new folder. Now when I go back to look at the Results Folder location, it is back to the folder in the vault that contains the part.

 

If I go to the vault folder and unselect the option to check in simulation results and then try to check in the part I see no cyclic references:

 

So, it appears that Solidworks PDM is incompatible with Solidworks Simulation. Fantastic!

 

OK, so I figure I've wasted too much time troubleshooting this software for SW, so I set the vault back to include the simulation results and save the part file. I get the error of unknown origin that says that it can't create a file in a directory that I have full access to. As there is nothing I can do at this point to make this error go away, I close the file. Now I open the file again to check that the simulation results are available and voila! - no results available. Changing the location of the Results file under the study properties makes no difference- but a least it seems to stay set to the same location after clicking OK.

 

 

So I remember the searching I did to try to find out how to re-establish the link between the simulation results file and the part file and I remember that I found: NOTHING. Nobody knows how to do this. Every single forum post says that I found that asks this question is un answered with the OP usually coming back and saying that they couldn't find any way to get SW to read the results file so they just gave up and ran the study again hoping that they will get lucky and the results will remain linked to the SW file.

 

In trying to recover, I was about to copy the version of the CWR file that got saved outside the vault back to the vault. To be safe I checked the CWR file in the vault and it was listed in the vault at 2.47 GB, while the one saved outside the vault was listed at 19.4 GB. So I decided to copy the 2.47 GB file to another location outside of the vault as a backup. As soon as it started copying, Windows tells me that the file is 19.4 GB and is listed as that size when done copying! Wonderful!

 

SW. PLEASE PLEASE PLEASE PLEASE.

 

IF A FEATURE DOES NOT WORK WITH ANOTHER FEATURE, DO NOT TELL US THAT IT DOES OR SHOW US HOW TO ENABLE THE INTEGRATION OF THESE FEATURES.

 

Does anyone know how to re-link the SW and simulation files? Is there a stand alone interface to the simulation engine? Maybe I can export and import the results?

 

Note to self - NEVER count on Solidworks when you have a deadline.

Outcomes