AnsweredAssumed Answered

Any way to turn off the triangle edge display of an STL import?

Question asked by Michael Van Dorp on Mar 25, 2019
Latest reply on Mar 28, 2019 by Michael Van Dorp

A bit of background: we have multiple large .stl scans that we use as a reference to design around. We are using solidworks 2018 SP4. We are importing the stl files as graphics bodies.

 

The .stl files when placed in an assembly display all of the edges of the facets and makes it so that solidworks is unbearable to work with. If I open the stl mesh as an individual part first, (before opening the assembly also containing the stl) then in the part file it does not display the edges and solidworks responds normally. If I open the assembly and then the part file then the part file also displays all of the edges and is extremely sluggish to respond.

Edges displayed:

Part file with same display settings but edges not being rendered:

 

One work-around that was mentioned on here is to use the "Shaded" display instead of "Shaded with Edges". With any of the .stl files that we had previoulsy imported solidworks does not display the edges of the facets. Any ideas?

Outcomes