AnsweredAssumed Answered

Motion Study won't update with changes and other general issues

Question asked by Nathan Huber on Mar 21, 2019
Latest reply on Mar 22, 2019 by Amit Nara

I've created a simple assembly with a screw and nut (acme thread, for a linear actuator). The parts are mated so that the nut accurately traverses the nut when rotated.

 

When I add a motor in motion study I can get the nut to accurately rotate down the screw. The problem arises when I try to edit the motor feature. I right click the motor, "edit feature", change the parameters (such as the angle I want the motor to rotate in oscillating mode), and attempt to play the animation. It will play what the original parameters were. I have tried the standard "refresh" and the motion study "calculate" prior to replaying the animation, but the animation won't update. The only option is to start a new study and delete the old one.

 

I've also tried using the "data points" option on a fresh motion study and can't get it to function. For example, in Time/Displacement mode, I've entered something like:

 

0 seconds, 180 degrees

1 seconds, -180 degrees

2 seconds, 360 degrees

3 seconds, -360 degrees

 

When I refresh, calculate, and play the nut rotates half a turn forward and half a turn back (good), pauses (bad), then a full turn forward and a full turn back (good), pause (bad) then jumps to the far end of travel (from the 360 rotation) and rotates back to the start position (bad), jumps to the far end AGAIN (bad), and rotates back to the start position (bad), before restarting. It doesn't matter if I have it in normal, loop, or reciprocating playback.

 

This is all in "Animation" mode because in "Basic Motion" mode I can't get the parts to animate at all.

Am I doing something wrong here or is motion study messed up?

 

I've attached a file with a different attempt (using the segment function instead (0, 180, 0, 360, repeat) which animates the sequence accurately before sporadically jumping all over the place like it's having a seizure. Basically nothing I try works as intended. I've tried outputting to video files and it shows the same issues as I saw in the Solidworks window.

Attachments

Outcomes