AnsweredAssumed Answered

Can't get CustomPropMgr.Get2 or Get4 to work in assembly

Question asked by Harold Black on Mar 18, 2019
Latest reply on Mar 18, 2019 by Harold Black

This question pertains to a macro I'm working on which collects all weldments with a length property and totals the lengths. I have posted questions before on here pertaining to this macro. This problem is in regards to Get2 and Get4. For some reason when I run my macro on the assembly I get CustomPropResolvedVal = ""LENGTH@@@TUBE, SQUARE 4.50 X 4.50 X 0.25<2>@Catwalk.SLDPRT"" when it should be returning me the value for the length. I've initially tried Get2 and then I tried Get4. When I run the macro on the part the code halts on, it runs fine and I get the results expected. I can't include my assembly or part files since I'm developing this code using a structural framework at my work as a test bench. I should note that this part has 6 total configurations. This shouldn't matter though since I don't get an error when I run the macro just on the part and not the assembly.

 

bool = CustomPropMgr.Get4(CustomPropName, False, CustomPropVal, CustomPropResolvedVal)

 

Message was edited by: Harold Black

Attachments

Outcomes