AnsweredAssumed Answered

Corrupted registry causes programs to misbehave. Yes it does.

Question asked by Tom Gagnon on Mar 12, 2019
Latest reply on Mar 12, 2019 by Tom Gagnon

EDIT: Original title, "Draftsight command D crashes it. Any other input I should avoid?"

 

I'm fairly used to Draftsight accepting text commands, and command abbreviations, similarly to AutoCAD. For examples, C command begins Circle command, REC command begins rectangle command, and L command begins Line command. If a command is not recognized, I expect it to return such as a text error message. I am familiar with and used to text commands over icon buttons or menu tools in 2D CAD.

 

Today, I was being lazy, so instead of clicking the Linear Dimension button, I tried DIM as a command, which returned, "Unrecognized command DIM. Press F1 for help." OK, what I should have used to get what I wanted was DIMLIN for Linear Dimension. That was not coming to mind, so I tried the command D. It appears to me that this command does not return as unrecognized, but just locks up the software (repeatably). Wow, Do Not Do That. I wish that I had saved more recently than I had, as I lost work in the lock up.

 

What would the D command be for if it is a valid command? Why wasn't it unrecognized? Should I have waited minutes or more for it to complete some task?

And more importantly, are there any other Draftsight input commands which we should avoid entirely to avoid software lock up?

 

Install reference DraftSight 2016 x64 SP0, on Windows 7 Pro x64.

Outcomes