AnsweredAssumed Answered

PDM Automatic Login & VPN

Question asked by Rich Harder on Feb 15, 2019
Latest reply on Jun 30, 2020 by Rich Harder

Is there a way to stop PDM from logging into the vault until it’s called on i.e., PDM folder selected, SolidWorks launched, etc. on our mobile workstations?

 

Our Archive Server Default Settings are set as Login > Windows Login > Automatic Login (Domain/Group).

Our PDM Client settings are set to Use Server Default.

 

When the laptop is powered on and not connected to the company network (prior to connecting to VPN) users receive the PDM message This will disable automatic login from the Explorer until next login.  Selecting Yes here deselects the Use Server Default option, disabling automatic login. It will stay this way, prompting for manual user login until going back into settings and re-selecting the Use Server Default option.  I tried disabling SolidWorks PDM in Windows Startup.  I also tried removing SOLIDWORKS 2018 Fast Start from C:\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp.  Still get the message.

 

While in Dallas at SolidWorksWorld I asked around.  I was informed that simply removing the PDM vault view from Windows 10 Quick Access would resolve this issue.  It does not.  I’ve removed the view and even cleared File Explorer history, removing all Quick Access items.  I continue to get the PDM disable message, deselecting the Use Server Default option.

 

There’s one last option I can think of that I've yet to try, but I’m currently waiting to see if IT will give me access to change it.  Under my Windows Power Shutdown Settings there’s the Turn on fast startup (recommended) option that is turned on, but grayed out to me.  I’ve asked if I can get this turned off to see if it will make a difference.

 

Is there anything else I might be missing?

Outcomes