3 Replies Latest reply on Mar 28, 2019 10:01 AM by Balaranga Polur

    Solidworks installation manager slows down to install

    Balaranga Polur

      SolidWorks 2016 SP04 installation manager slows down to install when Plastics or FlowSimulation.

      We don't see any pop-up also mentioning its failed.

      Need help in anlayzing, why its not installing. Am not getting any Error or Failed info from the logs.

       

      I have selected the FlowSimulation and its more than 6 hrs, tuck at 96 %.

      When checked the logs in %userprofile%\AppData\Roaming\SOLIDWORKS\Installation Logs\2016 SP4.0.

       

      09:59:58 Info Status 143 0 "CREATING INSTALL STEP 1 to Modify: prod=SolidWorks, code={768F3B65-1695-47B7-9002-B11400CB111D}, upg=, cost=4798191KB, force=0, patch=0, command=INSTALLDIR="C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS\" ADDLOCAL=Simulation REINSTALL=FeatureWorks,PhotoView,SolidWorksAnimator,SolidWorksToolbox,SolidWorksRoutedsystems,SolidWorksUtilities,ScanTo3D,CoreSolidWorksTaskScheduler,TolAnalyst,CircuitWorks,Motion,SolidWorksCosting,SolidWorksDesignChecker,RealViewGraphicsdisplay,ExampleFiles,Manuals,HelpFiles SLDIM=1 REINSTALLMODE=vomus REBOOT=ReallySuppress SERVERLIST="25734@SERVERNAME" TRANSFORMS="C:\TEMP\SOLIDWORKS 2016 x64 SP04\swwi\data\1033.mst" TOOLBOXFOLDER="C:\SOLIDWORKS Data\" OFFICEOPTION=3 ARPSYSTEMCOMPONENT=1 IMTOKEN=REPLACEME diskid=1"

      09:59:58 Info Status 143 0 "CREATING INSTALL STEP 2 to Install: prod=COSMOSFloWorks, code={0B7C2320-1D2F-42F1-9941-C88C6B7AB0D5}, upg=, cost=610681KB, force=0, patch=0, command=INSTALLDIR="C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Flow Simulation\" SLDIM=1 REBOOT=ReallySuppress SOLIDWORKSPATH="C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS\" ARPSYSTEMCOMPONENT=1 diskid=2"

      09:59:58 Info Status 139 0 "CREATING INSTALL STEP 3 to FINISH: cmd=, cost=87347KB"

      10:00:01 Info Step 90 0 "{0: Re-installing} MSI: {1: C:\TEMP\SOLIDWORKS 2016 x64 SP04\swwi\data\SolidWorks.Msi}; command-line: {2: INSTALLDIR="C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS\" ADDLOCAL=Simulation REINSTALL=FeatureWorks,PhotoView,SolidWorksAnimator,SolidWorksToolbox,SolidWorksRoutedsystems,SolidWorksUtilities,ScanTo3D,CoreSolidWorksTaskScheduler,TolAnalyst,CircuitWorks,Motion,SolidWorksCosting,SolidWorksDesignChecker,RealViewGraphicsdisplay,ExampleFiles,Manuals,HelpFiles SLDIM=1 REINSTALLMODE=vomus REBOOT=ReallySuppress SERVERLIST="25734@SERVERNAME" TRANSFORMS="C:\TEMP\SOLIDWORKS 2016 x64 SP04\swwi\data\1033.mst" TOOLBOXFOLDER="C:\SOLIDWORKS Data\" OFFICEOPTION=3 ARPSYSTEMCOMPONENT=1 IMTOKEN=REPLACEME}

      (ID {3: SolidWorks}, lang {4: }, pcode {5: {768F3B65-1695-47B7-9002-B11400CB111D}}, mode {6: 6}, upg = {7: }, f{8: 0}, costKB {9: 4798191})"

      10:00:34 Info Step 155 0 "** Install SUCCEEDED **"

      10:00:37 Info Step 90 0 "{0: Installing} MSI: {1: C:\TEMP\SOLIDWORKS 2016 x64 SP04\Flow Simulation\SolidWorks Flow Simulation.msi}; command-line: {2: INSTALLDIR="C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Flow Simulation\" SLDIM=1 REBOOT=ReallySuppress SOLIDWORKSPATH="C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS\" ARPSYSTEMCOMPONENT=1}

      (ID {3: COSMOSFloWorks}, lang {4: }, pcode {5: {0B7C2320-1D2F-42F1-9941-C88C6B7AB0D5}}, mode {6: 5}, upg = {7: }, f{8: 0}, costKB {9: 610681})"

      10:02:02 Info Status 58 55803 "Received data from Installation Manager server (Script: {0: http://im.solidworks.com/2016/Connect.aspx?Release=20160-40400-1100-100&Debug=0&ini=0&osa=8192:0:2&lid=1033&app=I&cx=4098:2&cm=-1&lfr=&lfp=&lfv=}, Code: {1: 0}, Error: {2: }, File: {3: <none>})"

      .......

      ........

      ........

      18:23:05 Info Status 58 55803 "Received data from Installation Manager server (Script: {0: http://im.solidworks.com/2016/Connect.aspx?Release=20160-40400-1100-100&Debug=0&ini=0&osa=8192:0:2&lid=1033&app=I&cx=4098:2&cm=-1&lfr=&lfp=&lfv=}, Code: {1: 0}, Error: {2: }, File: {3: <none>})"

      18:26:05 Info Status 58 55803 "Received data from Installation Manager server (Script: {0: http://im.solidworks.com/2016/Connect.aspx?Release=20160-40400-1100-100&Debug=0&ini=0&osa=8192:0:2&lid=1033&app=I&cx=4098:2&cm=-1&lfr=&lfp=&lfv=}, Code: {1: 0}, Error: {2: }, File: {3: <none>})"

      18:29:05 Info Status 58 55803 "Received data from Installation Manager server (Script: {0: http://im.solidworks.com/2016/Connect.aspx?Release=20160-40400-1100-100&Debug=0&ini=0&osa=8192:0:2&lid=1033&app=I&cx=4098:2&cm=-1&lfr=&lfp=&lfv=}, Code: {1: 0}, Error: {2: }, File: {3: <none>})"

       

        • Re: Solidworks installation manager slows down to install
          Balaranga Polur

          Figured out that the Windows installer "SOLIDWORKS Flow Simulation.msi" file used from the software install Directory location "C:\software_dump\SOLIDWORKS 2016 x64 SP04\Flow Simulation" is not functioning as expected.

          Double clicked on the "SOLIDWORKS Flow Simulation.msi" file, it moved only until License Agreement page as shown in below screenshots and showed the finish Page.

          Here we recognized that the Windows installer "SOLIDWORKS Flow Simulation.msi" was not functioning as expected.

           

          So, double clicked on the setup.exe file from the software install Directory location "C:\software_dump\SOLIDWORKS 2016 x64 SP04\Flow Simulation"

          It did showed the above mentioned three images.

          On click next button in the "License Agreement" window

          it routed to the "Specify License Information" window, on clicking Next button

          it routed to the "Server List" Window, on clicking "OK" button

          it routed to the "Destination Folders" window, on clicking "OK" button

          it routed to the "Ready to Install the Program" window, on clicking "Install" button

          "Installing SolidWorks Flow Simulation"  progress window is seen

          "completing SolidWorks Flow Simulation" window appears, click "Finish" button to close.

           

          Am not sure why only the Windows installer "SOLIDWORKS Flow Simulation.msi" is not functioning when we try add required features from

          Control Panel -> Programs and Features -> selected "SolidWorks 2016 x64 Edition SP4" -> Change.

           

          If MSI is not triggering the install, then how come the "SOLIDWORKS Composer.msi" got trigged to install automatically.

           

          Can SolidWorks Experts provide input on the MSI issue which is causing to failed installations when using "SOLIDWORKS Flow Simulation.msi.

          • Re: Solidworks installation manager slows down to install
            Balaranga Polur

            Downloaded the entire SolidWorks 2016 SP4 software.

            It also has the same issue.

            Seems something is wrong with MSI.