4 Replies Latest reply on Apr 4, 2009 2:21 PM by John Kreutzberger

    self-intersecting surface

    John Kreutzberger
      This may be more pertinent to the mold design forum, but is a surfacing issue. I have an imported part that I doing a core/cavity split for. I kind of use the mold tools, but not completely. I have all of my knit surfaces for core, cavity and parting surfces in the part file but for a few reasons that are not relevant to my problem I choose to do my split in the context of an assembly.

      I create my core and cavity blocks in this new assembly-then bring in the molded part and position it. I then edit the core and copy the core surface and the parting surface; knit them together and do my surface cut. No problems.

      Then when I try to do a similar thing for the cavity, I get an error message when I try to offset the cavity surface by a distance of zero: resultant body is a self-intersecting surface. News to me. I go back to the part and look it over and find no problems. Then I try to offset that same surface in the part file-just for grins. No problem-no error message-everything looks fine.

      I go back to the assembly and edit the cavity part and try to offset either one of these surfaces with no success. Anybody have any ideas on what is going on? A body check shows no problems, by the way.
        • self-intersecting surface
          Charles Culp
          I had the same issue last week. I was working with imported geometry, and I found a bad face. I just offset that face as a separate body. Seems really awkward though, since it was all part of a solid body.
          • self-intersecting surface
            check the model health, any short edges, vertex, gaps. etc....
            • self-intersecting surface
              When import the geometry ,increase the precision in the import options.
                • self-intersecting surface
                  John Kreutzberger
                  I never knew that SW gave us any control in this area. However, I just looked at the options tab when importing a step file and saw something I had never seen before.

                  Are you talking about checking the box that says: customize curve tolerance? Right now that box is unchecked but I can see that the default seems to be .00003937. I will try making this smaller in the future.

                  Your idea makes sense to me based on feedback I have gotten from SW. They have the file and also told me that it was a tolerance issue. Since this is a molded part, I have a scale feature in the tree before I created all of my surfaces for the mold split. SW is telling me that if they change the scale feature from .006 to .01-then everything works as expected. They are calling this situation a bug and have issued an SPR.

                  Thank you very much for your input.