AnsweredAssumed Answered

hide only one edge in drawing / Edge line color override overlaps annotations in PDF

Question asked by Tom Gagnon on Feb 1, 2019
Latest reply on Feb 1, 2019 by Glenn Schroeder

I'm detailing modifications that need to be made to a standard Shipping Container when we receive it, so some equipment can be mounted to its exterior, and other components penetrate its exterior through a hole. I did not design the container model, so I am uncertain of its exact accuracy. The line density of the corrugation obscures design intent of dimensions and balloon leaders. I'm trying to make it easier to read by altering line weight or color to de-emphasize the recessed corrugation edges, and retain normal emphasis on the exterior corrugation edges so that it carries design intent better, such as the weld studs must be placed on the exterior corrugation faces so that steel brackets can be mounted to them.

 

Model image:

containermodelCapture.JPG

 

I had pretty good results with assigning the recessed edges to be light grey (as long as its saved PDF is set to [x] Export PDF in Color). One remaining issue, however, was a panel edge, where one panel ends and is seamed with the next panel. This detail is mostly irrelevant in our use, and furthermore unreliable from a standard download which I did not design from "product in hand". So, I wanted to Hide specific selected Edges in the Drawing. I could not find a way to do this directly.

 

Drawing image:

containerdrawCapture.JPG

 

What I did which did work acceptably, is to select the seam and set its Line Color to White. Then, after exporting the PDF in color, the line is present as white on white, and then does not produce any line when printed for shop production. It does retain a minor artifact of the line, as its endpoints slightly overlap the horizontal edges at its top and bottom. As such, it is not purely hidden, but for the most part it does not show. But then, when gathering some screenshots to attach here, I noticed that every edge like with color override appears (in PDF only) ON TOP of the dimension and balloon leader lines. In this way, they appear "dashed" in the PDF output. I also tried adding a new dimension to it, thinking that the last modified item is 'on top', but the new dimension was partially obscured with the edge line that were colored just the same as the entities which existed before I changed edge colors. This leads me to an awkward series of questions as I try to make it appear better:

 

PDF export image:

containerpdfCapture.JPG

 

(1) Is there a different way for me to hide a single edge without color overrides?

(2) Is there any way to "Bring to Front" for annotations, either as a command, a setting, or a procedure of this before that?

(3) Should I just accept overlapping entities in the result, and move on?

(4) Is there a different PDF production variety to produce other results? I did Save_As.. PDF.

(5) Is there something else that I haven't even considered?

 

I'll try altering line weight instead of line color, and see it that changes the exported result.

References: 2018 SP5 installation, certified VC driver up to date, I tried a forum search before posting.

Outcomes