AnsweredAssumed Answered

SUB-ASSEMBLY REBUILD ERROR

Question asked by Joel Gilbert on Jan 18, 2019
Latest reply on Sep 13, 2019 by Scott Perman

Alrighty then! I have a couple of recurring issues with sub-assemblies that are driving me nuts. I mostly want to see if anyone else has had this happen, and if so, whether a newer SP or major version has fixed it. I'm running SOLIDWORKS 2017 SP2.

 

  1. In assemblies with a large number of parts and mates I will have everything fully defined with no errors, but while working on the drawing I'll see the rebuild error marks next to the model icon. If I open the assembly, I can sometimes just Ctrl-Q and Ctrl-B several times and the errors disappear. Sometimes I'll have to suppress a dozen or so mates, then unsuppress them and the rebuild error disappears. Of course at some random time in the future it will bring back the rebuild errors. I've had this happen on several dozen assemblies and I can't seem to find any logic as to what causes it. My initial hunch was using flexible subassemblies (which I don't like but in some cases is necessary), but I've gone to the trouble of creating a separate configuration of my adjustable pivots and other flexible parts and the errors remain.
  2. I have perfectly stable sub-assemblies that are fully defined and can be rebuilt over and over with zero errors or warnings. I put them into a top-level assembly and start putting mates together and after a couple dozen parts/sub-assemblies are mated I get rebuild errors in the tree. It usually starts when I'm mating to something completely separate from the subassembly that gets the errors. If I open the subassembly and rebuild, everything is fine, it's not over-defined, it's not missing references, nothing. I can save the file, go back to the parent assembly and rebuild and everything looks good until a couple rebuilds or mates later when it does it again. I've tried starting from scratch with a new top-level assembly and being ultra-careful with my mates and it still spits the dummy

 

Unfortunately due to company policy I can't share any of the files here, otherwise I would. If I have time tonight I'll try and put together a dummy model at home and try it (but I'm running 2018 at home and this may already be fixed). I would appreciate any advice or ideas to troubleshoot this, I'm hoping it improves whenever I can get IT to sign in as administrator and upgrade to SP5 but I have no idea if that's going to help.

Outcomes