3 Replies Latest reply on Jan 9, 2019 4:19 PM by Michael Mazon

    Mouse wheel click now only rotates view after selecting surface or edge

    Michael Mazon

      I previously would hold the middle wheel down anywhere and could move the mouse to rotate the view angle. Now I have to click on a surface or edge then click and hold the middle wheel while on that surface/edge to rotate the view angle. I have never experienced this issue before. This just changed suddenly without me making any setting alterations. I don't know if an automatic update perhaps changed some settings, but I have not been able to find any setting that would correct this issue. I am currently running SolidWorks 2017 SP5. Any ideas on how to fix this issue. Thank you in advance for your help.

       

      Also, now when I click on a surface, a normal vector to that surface appears and a tree above which I do not recall being there. I could be mistaken though.

        • Re: Mouse wheel click now only rotates view after selecting surface or edge
          Kevin Berni

          Hi Michael,

           

          What do you see for a cursor when rotating? Do you see this: or

           

          The little vector arrow  showing up when clicking on a surface is that you have Instant3D on. You can turn it off by clicking that button on the Features Tab of the command manager, or by typing instant3D into the search box and click on the icon next to the name that shows up in the results.

           

          The tree at the top left is the selection breadcrumbs.  If you don't want those, you can find the setting in Tools > Options > Display or just search for "breadcrumb" in the system options dialog.

            • Re: Mouse wheel click now only rotates view after selecting surface or edge
              Michael Mazon

              Hi Kevin,

               

              It depends. If I click with the left mouse button then shift the mouse over a bit the click and release the wheel, I see the first image with the dotted line. However, if I click with the left mouse button then hold the wheel button down, I see the second one. The second allows me to rotate the view angle.

               

              The vector arrow and tree options advise helped me remove these. Thank you. I was hoping this may have something to do with the main issue I am having, but after making these changes I am still having the issue of not being able to rotate the view angle without these extra steps.

               

              Thanks for the help!

            • Re: Mouse wheel click now only rotates view after selecting surface or edge
              Michael Mazon

              A colleague of mine just informed me of a change that occurred in the settings last week. Hopefully this will help anyone else who is having this issue. To fix this problem, I had to go to the 'Add-Ins' menu and uncheck the two boxes next to 'SOLIDWORKS Forum 2017'. After exiting and restarting, this issue was resolved.