8 Replies Latest reply on Dec 17, 2018 11:35 AM by james demarco

    3Dconnexion SpaceMouse Compact in Composer 2018

    Manfred Weber

      Dear Community Member,

       

      We are experiencing an odd problem: Our IT guy plugged in his very old 3Dconnexion SpaceNavigator and it worked straight away in our new installation of Solidworks Composer 2018. We, the users, have purchased the 3Dconnexion SpaceMouse Compact and these do not seem to work with Composer 2018. The 3D mouse works correctly on the same Win 10 - PC with the trainer software. Therefore, it is not an issue with missing connection or missing newest driver.

       

      Anyone out there, that knows how to fix this problem?

       

      The support of 3Dconnexion reckons, that Solidworks Composer bypasses the driver and somehow communicates directly with the device. I cannot imagine, why one would do that; It would be somewhat strange. And then again: Why would I care about how it is accomplished, as long as it works? If it would work.

       

      Thank you for your help in advance.

       

      Best regards from Switzerland

       

      Manfred

        • Re: 3Dconnexion SpaceMouse Compact in Composer 2018
          Thomas Kurtmann

          Dear Manfred,

           

          unfortunately not every 3-D Navigator from 3D-Connexion seem to work with Composer. I tried a wireless space mouse and it doesn´t work. I switched back to the old space mouse with wire connection which works proper. Don´t know if the problem is with 3D Connexion or with Solidworks.

           

          Best regards from Germany,

          Thomas

          • Re: 3Dconnexion SpaceMouse Compact in Composer 2018
            james demarco

            We are using them in Composer - not brand new, but my machine is the latest driver.  I am running a SpaceMouse Pro.  We have found if you set Composer mouse settings to anything other than default using the spacemouse will crash the software. Interestingly my menu shows this:

            Although I am running SW2018.  Perhaps this is why it works?

            Look in %AppData%\3Dconnexion\3DxWare\Cfg you should have a composer xml file

            • Re: 3Dconnexion SpaceMouse Compact in Composer 2018
              Tom Gagnon

              Manfred Weber wrote:

               

              "his very old 3Dconnexion SpaceNavigator"..

              The 3D mouse works correctly on the same Win 10 - PC with the trainer software. Therefore, it is not an issue with missing connection or missing newest driver.

              Your statement and reasoning are invalid. Of course the trainer software works out of the box with the driver out of the box. To work with software other than the 3DC utilities and trainer, you will need to update the driver. You just had said that it is very old. Go to their site. Download latest driver. Install it. I have deployed these numerous times, and this action is always what is necessary to get it to work when newly introduced to a PC. If you're not doing that, don't expect it to work correctly with any real design software.

               

              Or, go compare its driver version with the latest available on the website and verify that it is indeed updated. Then I will believe that your issue is not due to a "very old" out-of-the-box driver version which appeared to work as plug-and-play because it is included within the device.

                • Re: 3Dconnexion SpaceMouse Compact in Composer 2018
                  Manfred Weber

                  Hi Tom,

                  Thank you for your input. However, I am actually talking about the newest driver version 3DxWare 10.5.11 / 3DxWinCore 17.5.11.15451.
                  The very old SpaceNavigator is running with that same newest driver version (apparently there is only one driver necessary for all 3DC devices, which is a good thing). Problem remains. I am not losing hope.

                  Wishing you all the best   Manfred

                • Re: 3Dconnexion SpaceMouse Compact in Composer 2018
                  james demarco

                  Manfred,

                  I have attached an rtf document with some highlighted sections to try:

                  Update the highlighted sections and save it as an xml in the AppData location I mentioned previously - it should make it work.