0 Replies Latest reply on Dec 5, 2018 2:11 PM by Sam DesRoches

    Windows 10 Draftsight File Association Fix related to AutoCAD being installed

    Sam DesRoches

      Not sure if any one has any issues with this as well, but when I installed the free version of Draftsight on Windows 10 (both on my Microsoft Surface and desktop computer), it would give me the option to "Open in" Draftsight when clicking on .dwg or .dxf files, but the default choice would not "stick" when I checked "Choose another app" and checked "Always open in this app".

       

      The fix I finally figured out involves the file associations in the Windows Registry (Run command > regedit)

       

      FOR DWG

      HKEY_CLASSES_ROOT\.dwg      (OR HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.dwg, they're the same)

           (Default) should be DraftSight.Drawing

       

      HKEY_CLASSES_ROOT\.dwg\OpenWithprogids

           (Default) should be DraftSight.Drawing

       

      FOR DXF

      HKEY_CLASSES_ROOT\.dxf      (OR HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.dwg, they're the same)

           (Default) should be DraftSight.Drawing1

       

      HKEY_CLASSES_ROOT\.dxf\OpenWithprogids

           (Default) should be DraftSight.Drawing1

       

      And repeat for the other file associations you need (see the keys starting at \HKEY_CLASSES_ROOT\DraftSight.Drawing to figure out which one Draftsight uses for each file type)

       

      Note for this to work, you have to do the above, and then repeat the steps of right click file, click Open With, Choose another app, Select "Always use this app to open..." then click Draftsight and click OK.

       

      Not sure if this is an issue with how AutoCAD is a giant mess of files that takes over the registry or if the Draftsight installer has wrong coding for registry entries (it puts a subkey under .dwg called DraftSight.Drawing which was maybe meant for the (Default) string under .dwg, but either way, hopefully this saves some people some headaches.