Kyle Taylor

More 2019 Routing Issues

Discussion created by Kyle Taylor on Nov 28, 2018
Latest reply on Nov 28, 2018 by Kyle Taylor

I've seen some weird stuff in my SW days, but this just takes the cake. Hopefully someone sees this. 2019 on multiple occasions has changed dimensions in a route. This is absolutely unacceptable by all means of the word. If you input a dimension there is zero reason that it should ever be changed by the program. Now what we have here is a whole other can of worms. See the 82 3/8" dimension? See the next 2 screenshots? Those were taken about 10 seconds apart from each other. Nothing was changed, the sketch was never closed, nothing was touched. Simply zooming in and out of the sketch was MOVING parts of the route and changing the dimension. Not to mention 90% of the route decided it was going to become unsolvable when it was fine a minute ago. We've also been getting different dimensions between what is in the sketch and what is in the drawing. That is usually fixed by pulling the dimension again or going back to the sketch, but another inconvenience.

My next issue... the routing performance has become abysmal. I do not have a workstation card, so I get that part. Running an RX 480 on one machine and RX 580 on another. They have worked wonderfully until now. Any route sketch that becomes the least bit complex completely destroys performance. Like waiting 10 seconds to zoom or highlight a dimension. This has added HOURS of work over the last week. This was never the case in 2018. I also think this may be a side effect of "penetrations". We do a lot of welded pipe branches so we use the penetrate command often. It almost seems that the performance is also related to the number of penetrations used. Maybe something to look in to. Crashing has also become a matter of a mouse click. It HATES routing.

I've also mentioned this in a previous post, but I will bring it up again as it's becoming time consuming. Pipe schedules change to the lowest available option on the drop of a new flange, so we're constantly having to use "change pipe diameter" any time a new spool is created. Sometimes this causes issues in itself. You now get a warning about "face to face dimensions" (flanges face to face) that need to be changed. You can hit Yes or No. We often gap flanges to simulate the size of a valve so we hit No. Sometimes it works, sometimes it put the dimension back to 0 and we have to change it back. But no matter if you hit Yes or No and check "Do not ask me again" it will default to YES only for every other instance. I would expect that if I hit NO and check that, it should default to NO.

Is anyone working on routing for the next service pack???

 

Side note: I use my own routing library which is just the stock library with modified tables but I've tried the 2019 library and reinstalled multiple times.

 

 

1.PNG2.PNG3.PNG

Outcomes