12 Replies Latest reply on Nov 21, 2018 10:38 AM by John Wayman

    Hiding a sketch

    Chris Scougall

      This is more of a nuisance thing...

       

      after I create a sketch and and then use it to create a revolved feature, I then RMB on the sketch in the tree and select hide. it is still visible (grayed out) until I select hide again. is there a system setting that will completely hide it after selecting hide once?

        • Re: Hiding a sketch
          Glenn Schroeder

          When I close the feature manager after creating a Revolve the sketch is absorbed by the feature, and hidden automatically.  Is that sketch used by another feature, or was it created for and used by just this Revolve?

            • Re: Hiding a sketch
              Chris Scougall

              I just use it once for the profile of the revolve. I can hide it, I just have to RMB and hide it twice. I will try the toolbar hide option as suggested. I'm sure that will work.

                • Re: Hiding a sketch
                  Galdino Bahena

                  cool man good luck

                  • Re: Hiding a sketch
                    Glenn Schroeder

                    Chris Scougall wrote:

                     

                    I just use it once for the profile of the revolve. I can hide it, I just have to RMB and hide it twice. I will try the toolbar hide option as suggested. I'm sure that will work.

                     

                    There's something odd going on on your end.  The sketch should be hidden automatically when the feature is created.

                      • Re: Hiding a sketch
                        Josh Brady

                        Glenn Schroeder wrote:

                         

                        Chris Scougall wrote:

                         

                        I just use it once for the profile of the revolve. I can hide it, I just have to RMB and hide it twice. I will try the toolbar hide option as suggested. I'm sure that will work.

                         

                        There's something odd going on on your end. The sketch should be hidden automatically when the feature is created.

                         

                        There's no hope for it, Glenn.  The OP has no idea what he's doing, and the "correct answer" is throwing out the baby with the bathwater.  Just let 'em wallow.

                          • Re: Hiding a sketch
                            Chris Scougall

                            There's no hope for it, Glenn.  The OP has no idea what he's doing, and the "correct answer" is throwing out the baby with the bathwater.  Just let 'em wallow.

                             

                            Josh... please explain

                              • Re: Hiding a sketch
                                Josh Brady

                                Chris Scougall wrote:

                                 

                                There's no hope for it, Glenn. The OP has no idea what he's doing, and the "correct answer" is throwing out the baby with the bathwater. Just let 'em wallow.

                                 

                                Josh... please explain

                                As Glenn said... Your sketch should automatically hide after being used to create a revolve.  I don't know of a setting that can disable that.  After you RMB and hide it, Hide should not be available to choose.  Only "Show".   If your RMB menu still shows "Hide", you probably have a corrupt install, bad graphics card etc, or...

                                 

                                Hide/Show Sketches from the View toolbar is an ignorant suggestion, on the level of "My SW keeps crashing" "OK, uninstall and it won't crash anymore".  However, if it's good enough for you...

                                • Re: Hiding a sketch
                                  John Wayman

                                  Chris,

                                  Could you perhaps upload a file showing an example of the behaviour you describe, as most of us are not seeing that behaviour in our own installations of Solidworks?

                                  I wonder whether it is to do with your workflow: Are you creating a sketch and exiting, then selecting that sketch and using it to make a revolve?

                                  My workflow is to select the plane I will be sketching on, click Revolved Boss/Base and start sketching. When I exit the sketch and press the green tick to complete the feature, the sketch disappears inside the feature in the tree and is not visible in the model window.

                                   

                                   

                                  John

                                    • Re: Hiding a sketch
                                      Glenn Schroeder

                                      John Wayman wrote:

                                       

                                      Chris,

                                      Could you perhaps upload a file showing an example of the behaviour you describe, as most of us are not seeing that behaviour in our own installations of Solidworks?

                                      I wonder whether it is to do with your workflow: Are you creating a sketch and exiting, then selecting that sketch and using it to make a revolve?

                                      My workflow is to select the plane I will be sketching on, click Revolved Boss/Base and start sketching. When I exit the sketch and press the green tick to complete the feature, the sketch disappears inside the feature in the tree and is not visible in the model window.

                                       

                                       

                                      John

                                       

                                      That shouldn't matter.  I don't use Revolves much, but when I do I generally create the sketch first, and then close it and choose the "Revolve" feature.  The sketch is absorbed and hidden just like it does if you select the feature first, as you described.

                          • Re: Hiding a sketch
                            Galdino Bahena

                            If all else fails go to the toolbar -> view--> Hide / Show --> Sketches.

                            • Re: Hiding a sketch
                              Manish Panchal

                              Go to toolbar View-- hide/show--hide all types. It will Hide every time.