AnsweredAssumed Answered

Drawings keep crashing for all but simplest parts

Question asked by Scott Faulkner on Nov 19, 2018
Latest reply on May 2, 2019 by Scott Faulkner

Hi all. I've tried my hardest to find a solution to this issue on these forums, but nothing is fully helping (though there is a lot of helpful advice on here!). I'm hoping someone out there may have a suggestion for a fix I've yet to try.

 

I am running SW 2016 and 2017 on my Dell XPS 15 9560. Yes, the GTX 1050 graphics is not SW approved, so this isn't ideal. But it runs parts and assemblies fine for my purposes, so until I can justify getting a workstation I'd like to stick with it.

 

My trouble is when it comes to drawings. This wasn't an issue when I first got the computer, however now when I try and open or create a drawing for anything but a simple part, SW crashes and comes up with the message "Solidworks is out of memory, now terminating". When I can get the drawing to open for a few minutes, often the lines detailing the part edges will have disappeared in the various views. This only happens for views with "Hidden Lines Removed". If I switch all the views to anything else (i.e shaded with edges), the drawing functions fine and no longer crashes. I should add that this happens in both 2016 and 2017.

 

To fix this I've tried increasing the GUI objects, forcing Solidworks to use the GPU and not the integrated graphics card and increasing the virtual memory, none of which worked. Finally I saw a suggestion on a forum that creating a new Windows 10 user profile fixed a similar issue for someone. I tried this and in the new profile the drawings work 100% fine, no issues whatsoever. I was happy to have found the fix I needed, so I started going through the process of setting up this new profile like my old one to avoid having to switch between them whenever I want to edit a drawing. And now it no longer works anymore...

 

I really hadn't gotten far into the process of updating this new user profile. I had copied some user files over, linked Dropbox, and rearranged the start menu layout a bit. But once again to do any drawings I have to use a different, brand new, user profile.

 

If anyone has any insight into what might be causing this issue, or has experienced a similar problem, I would very much appreciate hearing from you!!

Outcomes