0 Replies Latest reply on Nov 2, 2018 6:58 AM by Davide Vertuani

    Configuration Selector or Equation Suppression not available

    Davide Vertuani

      Hi everyone.

      I'm facing a - strange - issue while managing equations and configurations in an assembly. The parts of the assembly have their dimensions governed by global variables, whose are defined using equations, while two different configurations are defined. In one configuration some parts have to be suppressed.

      When a part is suppressed it generates an error in the equations manager, for the equation is not pointing to a part anymore... so far so good.

       

      In the first version of the assembly I made I had the opportunity to suppress single equations in the manager by clicking right -> suppress -> select configuration but I couldn't see the configuration selector near my equations to have different values in different configs.

       

      Screenshot (14).pngScreenshot (15).png

      First image: suppression option visible; second image: no configs selection.

       

      So I made a new assembly from scratch; this time I can see the configuration selector near the equations and therefore have different values in different configs, but I'm not able to suppress single equations from the manager.

       

      Screenshot (17).pngScreenshot (16).png

      First image: no suppression option; second image: configs selection visible.

       

      I tried using the design table to suppress equations via command $STATE@[EQ_NUMB]@Equations but the assembly rebuilds without the changes to take places.

      I'm using SW2016.

       

      This issue is similar to the one described HERE - posted in 2016 and apparenly not solved yet.

       

      Any help would be welcome.

      Thanks!