AnsweredAssumed Answered

Solidworks Flow Simulation hangs when creating or viewing cut-planes

Question asked by Steve Camp on Oct 22, 2018
Latest reply on Oct 22, 2018 by Steve Camp

NOTE:  This post deals with SolidWorks Flow Simulation 2014.  HOWEVER, at the end of this missive, I ask if this behavior has persisted with the latest versions of SolidWorks 2018/2019.  That is, if I were to spend the $$ to either get back on maintenance, OR purchase a new license... will I just be buying myself more headaches, or have the issues described below been solved or addressed?

 

I think I'm out of luck with this issue, but c'est la vie.

 

Problem Description:  When creating a cut-plane to post-process the solution from Lesson 1 of the Solidworks Flow Simulation 2013 training manual, the application "locks up" or freezes.  Oh, the cut-plane is initially created lickety-split and looks nice, but any attempt to translate or rotate the model results in the spinning icon of slow-death, and eventually the window will grey-out or dim, and then Windows will pop-up and ask if you want to kill the program as it has stopped responding.  If I wait, it will typically return, tens of seconds or minutes later, and the "rotation" I had commanded will typically show up.  But it is no where near real time.

 

I am not presently on maintenance -- I was unable to continue paying for that out of pocket several years ago.  I am trying to work my way through several training manuals and hone my skills to make myself more marketable.

 

I believe this problem is the same one as what John wrote of here:  Solidworks flow simulation | MySolidWorks

 

When I had last used Solidworks 2013 / 2014 Flow Simulation on my Dell Precision M4600, it worked fine.  I recall no issues.  However, that machine was getting old, and the fan loud, so I acquired a Dell Precision M5510 with the Nvidia M1000M Quadro graphics adapter running Windows 7 Pro x64 with 32GB of RAM and a Samsung SSD.

 

What I have tried:

  1. I have run Solidworks in Software OpenGL Mode and the cut planes display fine, and I am able to rotate the model around without any issues.  I have entered Software OpenGL mode via Solidworks 2014 RX > (SolidWorks Safe Modes) > Click here to launch SolidWorks in Software OpenGL Mode as well as by starting SolidWorks 2014, then without any parts or assemblies opened, selecting  the radio check box under Options > (System Options) Performance > Use software OpenGL.
  2. Uninstalling the latest Quadro drivers I had downloaded from Dell and installed a few months back, and re-installing the earliest "certified" Dell Quadro drivers from 2016.  This either did not work, or I had system problems with those drivers.  (This was driver 362.13-quadro-whql.)
  3. I searched certified / qualified drivers at the Solidworks.com website and downloaded the Nvidia Quadro driver versions 362.13 and 375.63.  I installed the driver(s) one at a time, rebooted, and re-launched SolidWorks 2014.  Neither driver resulted in correct behavior -- and SolidWorks froze when, after having loaded the assembly, and Loaded the results, I right clicked on a cut-plot and selected Show.
  4. I have also tried the registry edit hack wherein, with SolidWorks closed, I have run regedit and re-named the SolidWorks 2014 key to SolidWorks 2014 Backup.  This reset the user interface to a brand new install, but did not fix the freezing problem when attempting to view / manipulate a cut-plane.
  5. I also made some adjustments via the Nvidia Control Panel such as Enabling overlay, specifying that OpenGL be run on the Quadro M1000M card, specifying that Solidworks run on the Nvidia M1000M card etc.  None of these changes appeared to have any effect on the problem.

 

My workaround:  run SolidWorks 2014 (or 2013) with Flow Simulation in Software OpenGL Mode.  OR re-host SolidWorks back on my older Dell M4600 with a Quadro 2000M graphics card, and verify it does not suffer the same fate.

 

Questions:

  1. Am I S.O.L. as I suspect I am?  This is the first time I have run across an instance where older software had major heart burn running on newer hardware.  But I guess I'm not surprised.  If software is written to use a standardized API (e.g. OpenGL) correctly, I would not expect this behavior, though.
  2. Is there anything else to try?  Should I even attempt to continue downloading and trying to use various Quadro drivers thoughout time?  (E.g. Nvidia has about 6-9 different certfified Quadro drivers on their website.)
  3. If I were to either put my license back on maintenance (will be expen$ive) or purchase another seat, should I expect to have problems running Solidworks 2018 or 2019 Flow Simulation on a Dell M5510 (or a M5520)?  I presume that if I go this route, I will want to move to Windows 10 Pro x64?

 

If you've read this far... thanks.

Outcomes