2 Replies Latest reply on Oct 17, 2018 10:12 AM by Jeff Niederman

    (GER/ENG)Solid Works Resource Monitor Problems

    Mark Niemeyer

      Jedes mal wenn ich SolidWorks 2018 SP4 starte ploppen unzählige fehlermeldungen auf die mir sagen mein verfügbarer Systemspeicher wäre kritisch und ich solle einige Anwendungen beenden um Ressourcen freizustellen.

       

      Von meinen 8GB Ram sind maximal 5GB in gebrauch wenn Solid Works läuft und auf meiner Festplatte sind noch über 100GB frei.

       

      Vielleicht hat jemand eine Idee warum das so ist?

       

      Habe noch im Anhang ein Bild mit der Meldung angefügt.

       

      English:
      Everytime I open SW 2018 SP4 it pops up loads of error messages concerning my systemmemory. It says its critically and i should close some Apps to get som ressources back.

       

      I got 8gb of ram while max 5gb used and i got more than 100gb free hard disk space

       

      MfG Mark

        • Re: Solid Works Resource Monitor Probleme
          Frederick Law

          It could be 2 solutions:

          Windows GDI object or Windows swap file size.

           

          You can try change Windows swap file size min and max to 3 x memory = 24 GB or more if you have space on hard drive.

          I set mine to 64GB.

           

          GDI fix require edit to registry.

           

          Swap64.jpg

          • Re: (GER/ENG)Solid Works Resource Monitor Problems
            Jeff Niederman

            Hi Mark,

            Thanks for the English translation.  Please have a look at this Knowledge Base article:

            MySolidWorks - Official SOLIDWORKS Community

            It has not yet been translated, unfortunately.

             

            The short answer is that the problem is excessive "Commit Charge" by your running applications.  Windows commits memory address space to applications and the maximum address space it can offer is your physical memory + your virtual memory.  You might have physical RAM left, but Windows can't use it anymore because it has already committed all of its address space to your running applications.  This warning is telling you that the OS is reaching the limit. 

            So, one solution is increase the swap file as Frederick added.  This raises your maximum.

            Another is to look at your running applications in Task Manager and find which is greedily consuming the "Commit Size."  Shut them down if you can.

             

            Jeff