2 Replies Latest reply on Oct 10, 2018 6:42 PM by Habib Ghalamkari

    How to change vba editor language?

    Habib Ghalamkari

      Before talking to our var, I thought someone here may have a suggestion for me.

      I'm looking for a way to change the language of vba editor of Solidworks to English.

       

      Here's a little bit about my environment.

       

      This PC is running on the English version of windows 10 pro. All applications, including Microsoft Office, Adobe pro and Solidworks2018 are installed and running in English.

      Even Office vba editor is in English.

      2018-10-10_11-04-55.jpg

       

      I don't have any application installed in Japanese.

      But since I'm working in a company in Yokohama/Japan, windows' local is set to Japanese.

      The only application that shows itself in Japanese is SW's vba editor.

      here's a screen shot of it:

      2018-10-10_11-12-45.jpg

      Is there any way to change it to English?

      and if SW is installed in English (Japanese language is not installed), why it's in Japanese?

       

      Because of I need to be in contact with our customers, I need to keep Windows locale in Japanese.

      Is there any chance here for me?

       

      Any comment and advice would be a great help.

      Thanks.

        • Re: How to change vba editor language?
          Cad Admin

          Double Check changing language for non-unicode programs...Double check these...

           

          • You must be logged in with an account that has administrative privileges in order to change the system locale.
          • The appropriate language packs should be installed on the operating system.

           

          View the System Locale settings for Windows
          1. Click Start, then Control Panel
          2. Click Clock, Language and Region
          3. Windows 10, Windows 8: Click Region
            The Region and Language options dialog appears.
          4. Click the Administrative tab
            If there is no Advanced tab, then you are not logged in with administrative privileges.
          5. Under the Language for non-Unicode programs section, click Change system locale and select the desired language.
          6. Click OK
          7. Restart the computer to apply the change.

           

            • Re: How to change vba editor language?
              Habib Ghalamkari

              Cad Admin wrote:

               

              Double Check changing language for non-unicode programs...Double check these...

               

              • You must be logged in with an account that has administrative privileges in order to change the system locale.
              • The appropriate language packs should be installed on the operating system.

               

              View the System Locale settings for Windows
              1. Click Start, then Control Panel
              2. Click Clock, Language and Region
              3. Windows 10, Windows 8: Click Region
                The Region and Language options dialog appears.
              4. Click the Administrative tab
                If there is no Advanced tab, then you are not logged in with administrative privileges.
              5. Under the Language for non-Unicode programs section, click Change system locale and select the desired language.
              6. Click OK
              7. Restart the computer to apply the change.

               

              As I explained above, I have to keep my system Locale to Japanese. I was looking for other options.

              The problem is the only application that shows in Japanese is VBA editor of Solidworks..
              Even VBA Editor of Microsoft Office is in English.