6 Replies Latest reply on Oct 12, 2018 6:52 PM by Keith Rice

    Solidworks Add-In - fails to load.

    James Dooney

      Hi all,


      I'm experiencing a similar issue from thread SolidWorks Addin not loading, however this is a 3rd party Add-In called XTract3D.

       

      The Add-In was working and now no longer loads. The DLL is in the right location and the Add-In is working on 2 other computers besides mine. I am using Solidworks 2018 Service Pack 3.0.

       

      • I have tried uninstalling and reinstalling as Administrator
      • I have tried repairing SolidWorks
      • I've tried removing all VC++ and reinstalling
      • I've tried removing all instances of the Add-In from registry.

       

      XTract3D.png

       

      Any assistance would be greatly appreciated.

      Thanks!

        • Re: Solidworks Add-In - fails to load.
          James Dooney

          No error message appears when I try to load the add-in, however if I manually try open the add-in with File -> Open, I get the following error: "Unable to initialise the Add-In Component".

          • Re: Solidworks Add-In - fails to load.
            Keith Rice

            It doesn't make much sense that it was installed in the x86 folder or that you're getting the "failed to initialize" error message when using File-->Open when the SolidWorks HKLM registry keys are present. You could ensure that SolidWorks is actually looking at HKLM\Software\SolidWorks\Addins\{your GUID} by changing the Description key value and then loading SolidWorks and seeing if the change is present when you mouseover the addin name in Tools-->Addins.

             

            Anyway, I also want to say that its not enough to simply install some programs as administrator if the addin is trying to modify a part of the hard-drive that requires admin access. For example, I've seen addins fail to load even though all of the registry is correct simply because they were trying to modify the contents of C:\Program Files during loading. Unless the user has full admin access or the program is modified to not touch that part of the disk, the addin will fail to load.

             

            Keith

            SOLIDWORKS API Training and Services