7 Replies Latest reply on Oct 2, 2018 3:24 AM by Martin Jensen

    SW 18 crashes on opening of drawing files

    Martin Jensen

      Hi

       

      For as long as I can remember at my current job, my colleague and I have experienced one specific crash (out of many) that is particular annoying.

      Our VAR have been on this since the beginning of July, that's almost 3 months, without finding the reason. So now I try to reach out to more people by posting here.

       

      The crash is happening when we open drawing files (sldrw). No specific drawing, no specific content, no specific location. It doesn't happen every time, but more randomly. After the crash, I can reopen that same file without any issues, and later it will crash on another file.

      We use CustomTools (CT) for batch exporting drawings to PDF and/or DXF. Since CT opens each drawing file, this crash occurs quite often during this export. At first we thought the issue was because of CT, but that is not the case. We also experience it with CT disabled, as well by using #TASK which I installed just a few days ago to handle some other operations in drawings.

      Every time this happens during an export, we have to start all over. Usually I'll deselect some of the largest files that did get exported, and eventually after a few export operations, all files will be exported. This entire process usually takes 2-2,5 hours for PDF-files depending on the amount of components. During that time, I'm not able to use SW, and I have to regularly check if it has crashed.

       

      Whenever it crashes, I have to manually close the task in windows task manager. It never ends automatically, but just stays with the error window saying "SOLIDWORKS 2018 has encountered a problem and needs to close. Generating crash report. Please wait..." - I've tried waiting for a few hours without it closing itself.

      It seems like there's no crash report related to these crashes, perhaps because of the manual shut down. In RX reliability it says "Killed by user" or "Terminated unexpectedly".

       

      We've tried many things to solve this problem, but nothing seems to work. Some of them being:

      Entire system reinstall

      Updating graphics drivers - tried the most recent from nVidia and the on from SolidWorks website.

      Changing graphic cards

      Increasing virtual memory - I have 32GB physical and now 20GB virtual (on SSD), but SW rarely uses more than 5-6GB.

      Used OpenGL instead of hardware graphics.

      SOLIDWORKS default registry

       

       

      Our setup includes:

      - SolidWorks 2018 sp 1.0 (yes we should update, but this crash also happened in previous versions)

      - SW PDM 18.1

      - CustomTools 2018 2.0

       

      My system:

      nVidia Quadro K2000

      Intel i7 5820K 3.3GHz

      Physical RAM 32GB

      Asus motherboard (Can't see the model)

      Windows 10 Pro