8 Replies Latest reply on Sep 24, 2018 11:41 AM by Ben Pratt

    How can I set scale of my view to work with small scale work?

    Ben Pratt

      Beginner here.  Two questions:

       

      1.)  I am working in very small numbers, mils primarily.  How do I set the scale of solidworks?  Currently I have to zoom far in to see the work, and the dimensioning is tough.

       

      2.)  when you create a new plane, how do you then change you view to look directly down on it?  I have this plane that is tilted at an angle, and I would like to just view from essentially a top view.

       

      Thanks in advance

        • Re: How can I set scale of my view to work with small scale work?
          Sameer Qureshi

          Hi Ben,

           

          By setting the scale I assume you mean setting the units? To answer your questions:

           

          1. Change the units to mm or customise them in the Document Options (Tools > Options > Document Properties (tab) > Units). You can also use the quick toggle in the bottom right corner of the SOLIDWORKS Status bar to change this. To stop you from having to zoom in so much use the F key keyboard shortcut to zoom the screen to fit to the geometry or click the button on the heads up view bar if you see it.

           

          Image 1: Units

          Units.png

           

           

           

          Image 2: Zoom to Fit

          Zoom.png

           

           

           

           

           

          2. In a similar fashion, when creating a sketch on a plane, use the (Ctrl+8) keyboard shortcut to go 'Normal To' which essentially looks directly at the plane you are working on. You can also get this normal to view to automatically occur when you start a new sketch, you can toggle it here.

           

           

          Image 3: Auto-rotate Normal To

          Autorotate.png

          You can also press the SPACEBAR and bring up the View Orientation Box and choose a specific view from there.

           

          I'd suggest searching the forums and SOLIDWORKS help files for the basic UI navigation options as it's the quickest way to find the options you are after.

           

          Thanks,

           

          Sameer

          • Re: How can I set scale of my view to work with small scale work?
            Ben Pratt

            Sameer,

             

            Thanks for the helpful tips.  These are all very good, and much appreciated.

             

            The ability to zoom is great, but the problem I am having is that when I draw in such a small scale, the dimensioning and lines of that preview state before you confirm dimensions doesn't even show up.  Which I believe is happening from the extremely small scale I am working with.  I don't believe there is a way to remedy this at this point.  In Autocad I can jut set limits to my drawing, and be able to play in those smaller scales.

             

            One last question if you have a minute.  If I am using a sketch tool such as a normal line, and immediately after entering my line I want to start at another starting point in the plane is there a quick key to cancel and restart the sketch tool?  At this point I have to click delete, and then go to the top of the screen and re-engage the line icon to restart.  In other software there was a means to do this, but wasn't sure if SW had this. 

             

            I will do my best to search out these answers in the future.  It gets hard as I don't know the best search terms and keywords to use.

             

            Thanks again for the help.

              • Re: How can I set scale of my view to work with small scale work?
                Sameer Qureshi

                Hi Ben,

                 

                I'm not sure I understand the exact issue you are seeing but you could try this option in the settings. This will scale the view to the first line you create in a new part (which essentially zooms in to your local work space if you are working in mm or less)

                 

                Scale.png

                 

                The second issue with having to jump out of the tool each time is easily resolved. Click the line tool and then draw your first line, click to place your first and second point, but then when the preview appears to 'continue the line' and place a third point...just double click the left mouse button. This will end the current line but keep you in the tool to carry on drawing lines.

                 

                Thanks,

                 

                Sameer

              • Re: How can I set scale of my view to work with small scale work?
                Glenn Schroeder

                You can go to Tools - Options - Document Properties - Dimensions, and change the font size to whatever you need.  There's also a setting in Options to display annotations flat to the screen that should probably be turned on if it isn't already.  I'm on my phone now so I can't find the exact location, but it should be easy to find using the Search function.

                • Re: How can I set scale of my view to work with small scale work?
                  Ben Pratt

                  Glen and Sameer,

                   

                  Thanks for the tips, very helpful once again.  The problem with the scaling is that when I am working tin the mils area like the circle below that .003"  I try and draw continuously in this state but drawing tools like a line of circle doesn't show up visually until I zoom out some considerable distance.  Figure this has to do with the scale for which I am working with?  Below is a picture of where my cursor is relative to my first pic point in the center of my first extrusion.

                   

                  • Re: How can I set scale of my view to work with small scale work?
                    Andreas Rhomberg

                    Maybe changing the Image quality to  high will help?

                    • Re: How can I set scale of my view to work with small scale work?
                      Ben Pratt

                      Thanks for all the help on this.  It came down to me improperly having the grid/snap options set.  Once I eliminated those I have been able to work without this issue.

                       

                      Apologies if I wasted anyone's time, and thanks for all the help.