36 Replies Latest reply on Sep 18, 2018 2:48 PM by Dan Pihlaja

    How do you remove virtual sharps?

    Jody Holm

      I made a sketch in my model. I used the fillet command to create the radius in the corners. This automatically creates 2 lines that obviously show the sharp corner before the chamfer was put in. I do not want these lines in my sketch...that's why I put the fillet in. This sketch is carried over to a drawing and is a crucial

      piece of geometry beyond just the sketch in the model...and the drawing  for that matter. I certainly do not want them in my drawing. How do I get rid of those lines? They are of no value.

        • Re: How do you remove virtual sharps?
          Newell Voss

          Do you really need to remove them? Since it doesn't look like you use that sketch for anything on the print, why not just hide all your sketches? Otherwise you can delete them and dimension your sketch differently. Or just change the style under the document settings.

            • Re: How do you remove virtual sharps?
              Jody Holm

              Yes, I need to remove them. This sketch will be used for cnc programming, outside venders will be using this geometry for different processes as well.

                • Re: How do you remove virtual sharps?
                  Josh Brady

                  Jody, they are not lines.  They're virtual sharps.  The entity is actually only a point.  Note that you can select them only at the point where the two witness lines cross.  I'm not sure what they turn into when you export to DXF...  You can delete them from the sketch, and you can also change their display on a document-by-document basis (not a system option) on this dialog:

                   

                  Interestingly enough, if you put a part with one virtual sharp display style into an assembly that's set to display a different way, the sharps switch back and forth as you switch active documents.  So if you rebuild the part in its window, it will show its style sharps in the assembly when you switch to it, until you rebuild the assembly at which time the sharps will display per the assembly setting even in the part window.

                   

                  Unfortunately, for me the "None" setting doesn't seem to work - 2018 SP3.  Setting to "None" looks the same as "Witness" except that the two lines just meet at the corner rather than slightly crossing.  The only way to make them disappear altogether is to actually click the point and delete it.

                  • Re: How do you remove virtual sharps?
                    Newell Voss

                    So it is a finished profile boundary? Why not just model it as such and let the manufacturer decide the stock size? In any case, deleting wireframe (sharps) in programming packages is simple to do also so I fail to see the problem with just calling it out as needed on the print. You can offset the sketch to float above the part so there is no confusion/error/contact when milling the 3D portion.

                    Otherwise use my initial suggestion of re-dimensioning your model accordingly.

                • Re: How do you remove virtual sharps?
                  Glenn Schroeder

                  Can you do a Pack and Go of the Drawing into a zip file and post it here?  I'm curious why there isn't a virtual sharp in the lower right corner in either screenshot.

                    • Re: How do you remove virtual sharps?
                      Jody Holm

                      Here is the model. The drawing just depicts whats on the model. It probably has something to do with the relations I put in place before I put the fillets in, but I don't see why that should be an issue.

                        • Re: How do you remove virtual sharps?
                          Glenn Schroeder

                          I see two options off the top of my head (I'm sure there are more).

                           

                          1.  Edit the sketch in the Part and delete the virtual sharps.  This will also remove the dimensions.  You can add them back in, choosing the existing lines.

                           

                          2.  Use the sketch as-is in the Drawing.  Select the lines you want to show, recreate them using the "Convert Entities" sketch tool, and then hide the sketch.  If you have already added some dimensions to the sketch they will likely disappear when you hide the sketch.  If that happens, right-click on the sketch in the tree and choose "Show Dimensions" from the drop-down menu.

                      • Re: How do you remove virtual sharps?
                        Danny Edwards

                        I have notice this myself in some cases. If you make the fillets first then add your dimensions for your width and depth then you will not get the virtual sharps.

                        • Re: How do you remove virtual sharps?
                          James Riddell

                          Have you tried a virtual deburring tool?

                          Kidding aside, there is a check box when you create a fillet in sketch to 'Keep constrained corners'.  Did you try de-selecting that?

                          • Re: How do you remove virtual sharps?
                            Danny Edwards

                            This is what James Riddell is talking about.

                            If you de-select this option it does not but the virtual sharp. You get the shape but also you lose the dimension of the rectangle. You will have to add those back in afterwards.

                              • Re: How do you remove virtual sharps?
                                James Riddell

                                Danny Edwards, if you add dimensions prior to the fillet, those dimensions (line-to-line) remain after the fillet in the version I'm using.

                                  • Re: How do you remove virtual sharps?
                                    Danny Edwards

                                    Mine went away. I am SW2017 SP5.

                                      • Re: How do you remove virtual sharps?
                                        James Riddell

                                        I've got the same version, maybe it is different when you draw a rectangle vs. just lines?  When I dimension a rectangle (or other closed shape) then all the dimensions remain.  I almost always dimension to lines instead of the center point of a line.

                                          • Re: How do you remove virtual sharps?
                                            Danny Edwards

                                            I used the center rectangle closed shape then added the two dimensions to constrain. The I added the radius to all the corners with the box un-checked and the two dimensions went away for the rectangle. I dimension the lines instead point to point. I guess there is more to learn.

                                              • Re: How do you remove virtual sharps?
                                                Dan Pihlaja

                                                Here is an illustration:

                                                The numbers represent mouse clicks:

                                                 

                                                Way 1 to create a distance dimension:

                                                 

                                                Way 2:

                                                 

                                                These two dimensions are different in that, way 1 is a distance between the two vertical lines.  While way 2 is a distance between the 2 endpoints of the line.

                                                 

                                                The subtle difference shows up when you fillet or chamfer the corners (or any other function that changes the length of the line):

                                                 

                                                Again...numbers represent mouse clicks:

                                                 

                                                Then hitting the green check:

                                                 

                                                Notice that the dimension that was from point to point (rather than line to line) disappeared?

                                            • Re: How do you remove virtual sharps?
                                              Dan Pihlaja

                                              Danny Edwards wrote:

                                               

                                              Mine went away. I am SW2017 SP5.

                                              There is a GIGANTIC difference between dimensioning the length of an edge of a rectangle and the distance between two edges of a rectangle.

                                               

                                              They look the same in the end...but they are not the same.

                                               

                                              When you create a fillet on a corner of that rectangle, you are, in essence, shortening the edge length.....If your dimension is the length of one edge, then you are, by default, removing the two end points that the dimension is attached to.

                                              However, when you add a dimension from one edge to another (by selecting smart dimension, then selecting one edge....then selecting the opposite edge), now the length of the lines is independent of this.

                                              • Re: How do you remove virtual sharps?
                                                Josh Brady

                                                Danny Edwards wrote:

                                                 

                                                Mine went away. I am SW2017 SP5.

                                                Again, the key is how you define the dimension.  There's a difference between clicking one line and placing the dimension vs. clicking the two sides and THEN placing the dimension.  When you just click on the line (any line), what actually gets created is a distance between the endpoints of the line.  Therefore, when you chop off the line's endpoints with a fillet, what the heck is SW supposed to do?  If you don't check "keep constrained corners", it has to delete the dimension because that point goes away.  If you do check "keep constrained corners", it has to put something out there for the dimension to be attached to.  So it puts a sketch point out there and adds a "coincident" constraint to each of the lines that's getting chopped off.

                                                 

                                                However, when you dimension between the two sides, it actually makes a dimension between the two lines you click.  Filleting the corners doesn't make the lines go away, so you don't lose the dimension, even if you don't check "keep constrained corners".  In fact, even if you have "keep constrained corners" checked, the virtual sharp won't be created because the corners are not constrained.  The sides are.

                                                  • Re: How do you remove virtual sharps?
                                                    Danny Edwards

                                                    Thanks Dan Pihlaja and Josh Brady. That is what I was doing wrong. I usually select both lines instead of just the one. I was in a hurry. I will keep this in mind next time. Might make my life simpler.

                                                    • Re: How do you remove virtual sharps?
                                                      Jody Holm

                                                      If you do check "keep constrained corners", it has to put something out there for the dimension to be attached to.  So it puts a sketch point out there and adds a "coincident" constraint to each of the lines that's getting chopped off.

                                                       

                                                      I agree with all this. I just wish it did not have to actually "show" the virtual sharp. The process is good but the visual result is bad.

                                                        • Re: How do you remove virtual sharps?
                                                          Glenn Schroeder

                                                          Jody Holm wrote:

                                                           

                                                          If you do check "keep constrained corners", it has to put something out there for the dimension to be attached to. So it puts a sketch point out there and adds a "coincident" constraint to each of the lines that's getting chopped off.

                                                           

                                                          I agree with all this. I just wish it did not have to actually "show" the virtual sharp. The process is good but the visual result is bad.

                                                           

                                                          It doesn't.  Have you looked at the screenshot early on from Josh, and which I referred to several replies back?  If you select "None" at Tools > Options > Document Properties > Virtual Sharps then they won't show.

                                                            • Re: How do you remove virtual sharps?
                                                              Jody Holm

                                                              Yep, I saw it but it is not the case (doesn't work) in my sketch. Open up my model. Check "none" in your options. Delete the fillets by trimming or deleting. Trim the lines so the corners become sharp again. The rectangle is now fully constrained again. Next add the 4 fillets. You will see the virtual sharps still appear.

                                                              • Re: How do you remove virtual sharps?
                                                                Josh Brady

                                                                Glenn Schroeder wrote:

                                                                 

                                                                It doesn't. Have you looked at the screenshot early on from Josh, and which I referred to several replies back? If you select "None" at Tools > Options > Document Properties > Virtual Sharps then they won't show.

                                                                 

                                                                Actually, this doesn't work.  I went back and edited my reply... At least in 2018 sp3, the "None" option actually looks the same as the "Witness" option except that the lines don't actually cross at the point.  This would certainly seem to be a bug...

                                                                  • Re: How do you remove virtual sharps?
                                                                    Glenn Schroeder

                                                                    Josh Brady wrote:

                                                                     

                                                                    Glenn Schroeder wrote:

                                                                     

                                                                    It doesn't. Have you looked at the screenshot early on from Josh, and which I referred to several replies back? If you select "None" at Tools > Options > Document Properties > Virtual Sharps then they won't show.

                                                                     

                                                                    Actually, this doesn't work. I went back and edited my reply... At least in 2018 sp3, the "None" option actually looks the same as the "Witness" option except that the lines don't actually cross at the point. This would certainly seem to be a bug...

                                                                     

                                                                    SW2018 sp 4 here.  I started a new Part, changed that setting from Point to None, started a sketch, placed a rectangle, and used the sketch fillet tool to round off the corners.  No virtual sharps appeared.

                                                                     

                                                      • Re: How do you remove virtual sharps?
                                                        Jody Holm

                                                        Have you tried a virtual deburring tool?  Now we're getting somewhere!

                                                        Well. I think the answer is "No, you can not remove them." But, there are ways to create the sketch so they do not appear in the first place.

                                                        It all has to do with constraining the sketch before you add the fillets....mainly mid point constraints. Don't do it. Add the fillets first and then and your constraints. Here is a message I see often that pretty much assures you there may be trouble ahead. Thanks for the replies.

                                                        • Re: How do you remove virtual sharps?
                                                          Glenn Schroeder

                                                          Dan Pihlaja  and Josh Brady made an excellent point.  I made it a habit years ago to dimension between parallel lines whenever possible.  In addition to the reasons they listed, when manually adding dimensions in a Drawing this allows you to move the dimension from one side to the other and keep the extension line gaps.