AnsweredAssumed Answered

Errors on Random Parts

Question asked by Matt Zellmer on Sep 18, 2018

For the last few weeks I have been randomly having issues opening some parts but not all. First it started with a simple o-ring and not just the .SLDPRT file but also a .STP and .X_T file of the same part created before I started having issues. Now I am trying to complete a DriveWorksXpress tutorial but I can't because I can't open 3 of the parts.

 

When I open an assembly with the parts inside it I get this error (I am putting <file name> instead of the full file name):

SOLIDWORKS encountered an error opening <file name> as a reference.

Try opening the file in its own window.

 

So if I try to open the part directly i get this error:

SOLIDWORKS encountered a problem in the file: <file name> The body data is still intact.

Do you want SOLIDWORKS to recover the geometry from the part?

(Note: The feature history will be lost)

If I click the "Yes" button Solidworks crashes and if I click "No" it aborts opening it. Sometime clicking "Yes" works but the part come in as an imported body with no features or configurations.

 

If anyone else opens the parts on their computer everything works fine. It happens to random parts from all over including in our PDM, downloaded files and newly created files stored locally.

  • Tried reinstalling with no improvement.
  • Ran Solidworks through Solidworks RX with the options to bypass the Tools/options settings ("Safe Mode") and I could actually open the parts fine. I then matched my normal Solidworks setting to exactly match the setting from the "Safe Mode" setting which didn't help.
  • Removed all my macros I use, again no change. The only Tool I am using is DriveWorksXpress and I had these issues before I activated it.
  • Tried turning off all add-ins except for PDM with no change.

 

Checked the reference in the Open menu and everything is fine there for those parts. It seems completely random which parts this will happen with where some parts won't work but several other parts will work just fine in the same assembly.

 

I am not sure what else to try from here, I can't work normally in the "Safe Mode" to get things done that I need to but I am at a loss. Next step is I am going to reach out to my VAR but I don't expect much of a response from them.

Outcomes