AnsweredAssumed Answered

Description Property in the ToolBox...maybe any property?

Question asked by Matt Juric on Sep 7, 2018
Latest reply on Sep 11, 2018 by Ruben Balderrama

I'm attempting to work with our existing toolbox. I'm experimenting with an off line ToolBox. I changed a few things and plopped down a BOM. The first thing I noticed was that there was no "Description" property. So I went to the Config for the TB and added a description. Voila! shows up in the BOM. However I knew a description showed up in the BOM from our standard TB. IE the description in the BOM for a SHCS would be "SOCKET HEAD CAP SCREW". I then pulled up the standard TB and looked at the TB configuration and none of the fasteners had description in the data base. I then pulled up the template model for the fastener and someone had added a custom property to that model called "Description" and "SOCKET HEAD CAP SCREW".

 

I then went back to my local TB and did the same thing and got the same result, which one would expect. However this raised the question of

 

Which is the best/proper way to get a description/property into a part in the toolbox?

          1) Add that property to the model

          2) Add that property to the database

 

All of this monkeying around created a problem for me as well. On my local drive I went back and deleted the description in the template model. However now it will not pull the description from the data base. My guess is that there is some link that got broken once a "Custom" property was added in the model. Since this has already been done in our already existing TB and I will be starting with a copy of that is there anyway to reconnect this link if the answer to the above is to add the "Description" to the data base rather than modify the model. I guess I don't have to worry about it if the answer is to modify the template model.

 

I added a few pics below for clarity and I apologize for the wall of text.

 

Description added to TB model.

Nothing in Database

Thanks,

 

Matt

Outcomes