11 Replies Latest reply on Sep 5, 2018 12:37 PM by Deepak Gupta

    Surface-finish in note from library gives broken link

    Sergio Monti

      Hello, I'm trying to make a standard note for surface finish to drag from library.

      I created the 'Note' annotation inserting the symbol

      between brackets, spaces and comma getting the following note

      Then I saved it in the library.

      If I try to insert the note from library to a new drawing I get the following:

      What am I doing wrong?

        • Re: Surface-finish in note from library gives broken link
          Kevin Chandler

          Hello,

           

          It's not just surface finish symbols.

          This error appears for each of these entities (datums, GD&T fames, etc.) inserted into a note, saved as a library feature and then added into any drawing other than the source drawing.

          There's no option for breaking references either, like with assemblies.

           

          This works with text-only notes though.

           

          Seems like it should work as it does for text-only, so perhaps you can report this discovery to SW as incorrect behavior.

           

          Sorry, not much help,

           

          Kevin

          • Re: Surface-finish in note from library gives broken link
            Kevin Chandler

            Hello,

             

            Mr. Schroeder's reply reminded me of another method: blocks.

            Create the note as usual, save it as a block (renamed according) in the same folder as your Library notes are stored.

            Then drag and drop the block onto your new drawing and it works.

            But for some reason, the block version shrinks the surface finish symbols (highlighted), but when you explode the block (an exploded copy of the block is on the right), they're restored:

            This is on a new drawing, not the original where I created the note and block.

             

            Perhaps this is a workaround for you until you upgrade to SW2018 sp4 as Mr. Gupta mentioned.

             

            Kevin

              • Re: Surface-finish in note from library gives broken link
                Sergio Monti

                Thanks Kevin, that's could be a good option for me at the moment, as I need to explode it anyway to change values (it' quicker that edit the block) so I will mark your answer as correct.

                Sorry Glenn I know your solution in good, too!

                I did some trials and it looks like I don't have issues with shrikage of symbols.

                I also experienced the problem with the wrong scale importing block containing note and lines, and, as well, I solved the issue exploding the block.

                I noticed that the problem occurs on notes included in sub-blocks and I believe it depends on difference between the actual scale of the drawing and the scale of the drawing of the block when it was created.

                Apparently SW is able to recalculate font dimension on blocks according to the actual scale of the drawing but is not able to do it on blocks included inside the block (sub-blocks).

                Look at the example below.

                The block was crated on a drawing with sheet-scale 1:1. When imported on a drawing having sheet-scale 1:2 is like: 

                after been exploded is like:

                '12' and '10' are notes inside the block but

                is a 'block inside the block'. Once exploded it becomes a 'first-level' block and SW is able to calculate the correct font size.

                This is my understanding to the 'strange' behaviour.