AnsweredAssumed Answered

Issue with cosmetic thread in design table

Question asked by Devon Berman on Aug 14, 2018
Latest reply on Apr 17, 2019 by Hasanain Shuja

I'm trying to use a design table to model a family of screws. I have all of the physical traits worked out, but I'm running into issues with the display of a shaded cosmetic thread. The cosmetic thread feature tool has a drop down for thread size and I can't seem to figure out how to change that from the design table. If I select a thread, say #0-80, and move to another configuration, the #0-80 persists and causes an error if the screw size is out of range. If I then change the drop down to the correct value, say #10-32, then when I go back to a smaller screw, the same error exists for the out of range diameter.

 

I'm using the thread dimensions D1@Cosmetic Thread1 for the thread length, which seems to be working for full and partial threads. I'm trying to use D2@Cosmetic Thread1, but that doesn't seem to change anything. I put in all major diameters for D2, and I have noticed that when I move the drop down, a 1/2"-13 thread changes D2 from .500 to .408in, which I assume is the minor diameter. So I tried plugging in minor diameters for all D2 values, but that didn't fix the thread drop down issue.

 

Anyone know how to drive the thread drop down?

Outcomes