AnsweredAssumed Answered

"Some chamfered items are no longer in the model..."

Question asked by Sergey Feingold on Aug 14, 2018
Latest reply on Aug 14, 2018 by Sergey Feingold

Based on the results of my searching so far, it appears we're fast approaching the 10 year anniversary of this issue never being solved. Awesome. Now then...

 

Like many others I have encountered a problem with the "sketch driven pattern" inside a part. In my case I created a table-driven hole pattern, and certain hole locations need to be counterbored. I added cut-extrudes for the counterbores and as a result lost the far-side chamfer/countersink, so I recreated it with an additional chamfer feature, then a second chamfer on the counterbore. See image.

 

I can pattern the cut-extrude just fine, but Solidworks absolutely refuses to pattern the chamfer from a sketch. I've tried both the geometry pattern option  - where I get an error about how it can't do a geometry pattern - and the non-geometry pattern, where I get error in the title. The sketch from which the pattern is derived works fine for the cut-extrude, and it does not have a point at the reference location. There are no dangling points elsewhere, they're all exactly where they should be. I've tried doing the chamfers separately and together, same result. Of course, as always, they preview perfectly and then Solidworks bumps its head.

 

I thought "Maybe this is a multibody part so SW gets confused by the extra bodies," so I moved the pattern feature to before the extra bodies are inserted. Same thing. "Some chamfered features are no longer in the model." What does that even mean?

 

WHY can't Solidworks do this? What workarounds exist? I'm extremely tired of hour-long parts taking over a day because of constant little errors like this that take hours to ferret out. "Here is a chamfer, put it in these locations also." What am I missing???

 

 

2018-08-14 13_17_43-SOLIDWORKS Premium 2017 x64 Edition - [MODULE_ALL_MASTER.SLDPRT _].png

Outcomes