7 Replies Latest reply on Aug 16, 2018 7:15 AM by Gordon Rigg

    trailing zeros in angular dimensions

    Gordon Rigg

      My angular dimensions are showing two decimal places always. 30.00 for example.

      My linear dimensions have functioning smart trailing zeros. 110.15 or 110 instead of 110.00

      Why are my angular dimensions not behaving the same? There does not seem to be a different setting for trailing zeros on angles compared to linear dimensions.

        • Re: trailing zeros in angular dimensions
          Jim Sculley

          The trailing zeros display when set to (Smart or Standard) is specific to metric dimensions only.  Angle dimensions are measurement system agnostic.

          • Re: trailing zeros in angular dimensions
            Glenn Schroeder

            I've been playing around with this.  If you don't want decimals to show up on angles at all you can get that by selecting None in the Decimals column of the Angle row in the table at Tools > Options > Document Properties > Units, and also at Tools > Options > Document Properties > Dimensions > Angle in the "Precision" box, near the middle of the dialog box.  However, if some angles aren't even numbers, and you want that to show, then they won't.  I can't figure out how to make them "Smart", although there may be one.  I've just set mine to show one decimal, which is the most I ever want to show, and then if I don't want any to show I override it in the dimension's property manager in the drawing.

             

              • Re: trailing zeros in angular dimensions
                Gordon Rigg

                I currently have 2 dec places, and I'm fed up of having to change every angle dimension to get rid of the x.00 but I want to know if for some reason i have 30.01 degrees when it should be 30, so I don't want to just switch the resolution down to whole degrees.

                This was the best I could do though after fiddling about when I set up my drawing standard years ago, but thanks for your efforts Glenn Schroeder finding it is still exactly the same.

                It looks like this is another hole in SW drawing standards that we have been putting up with year after year after year.

                But they say it is fixed. Never mind the fact that it actually isn't fixed.

                 

                According to SPR# 817139 this is fixed in 2015 sp5, first reported in SPR#454165  back in 2009.
                However this is clearly not fixed in 2016 SP5 that I am using so AS USUAL the SPR listed as fixed is an absolute blatant lie.

                I have yet to actually find one that said fixed and was true.

                I also think that they actually made the knowledge base deliberately impossible to copy and paste, so we have to waste time doing screen grabs just to communicate with  each other about them (only available to those paying our annual thousands to SW of course, for what exactly I'm not really sure )

                 

                 

                 

                spr1.png

                SPR2.png

                  • Re: trailing zeros in angular dimensions
                    Gordon Rigg

                    So I email my VAR and see what they say:

                    I have been unable to get trailing zeros to work in a smart way on angular dimensions in drawings.

                    I want decimal places to appear if the angle is not an integer – but not to appear when the angle is an integer value. This is how linear dimensions behave by setting the trailing zeros to “smart”.

                     

                    However there is no such smart setting that applies to angular dimensions that I can find.

                     

                    I could set the resolution to zero decimal places but this is not desirable as I will not find out when an angle that should be an integer is slightly wrong.

                     

                    I have so far set the resolution to 0.00, and every time I apply an angular dimension that is an integer, I have been manually changing every single one to zero decimal places to get the numerical display required.

                     

                    This issue has been reported over many years and has SPR numbers 817139, and 454165.

                     

                    According to SPR 817139 this is was ‘fixed in 2015 SP5’, but myself and others have been unable to find any implemented solution. Perhaps you can guide us to a way to achieve smart trailing zeros in angular dimensions? Or resurrect the SPR if its fixed status is misleading as I suspect it is.

                     

                    Regards....

                • Re: trailing zeros in angular dimensions
                  Gordon Rigg

                  This is fixed in 2018, and possibly 2017, but not in 2016, despite the SPr stating its fixed in 2015...

                  fixed.png

                  not there in 2016 sp5...

                  2016 not fixed.png

                  I guess angular running and angular have the same options...

                  • Re: trailing zeros in angular dimensions
                    Gordon Rigg

                    I have to eat humble pie here!
                    I had a custom drafting standard based on one from about 2010 or so.
                    Now I fiddled about a bit, the control of trailing zeros in linear and angular dimensions (including the angle in the chamfer dimension that was particularly pesky) is working correctly.

                    The enhancement in 2018 gives independent control of trailing zeros in angular dimensions.

                     

                    I'm left only with the problem of no trailing zeros in the bilateral tolerances, when they are correctly applied to limit tolerances. This is the same on angular and linear dimensions.

                     

                    tolernaces.png

                    Addendum: from whats new in 2018

                    To set trailing zeroes in tolerances:

                    1. Click Tools > Options > Document Properties > Dimensions.
                    2. In Zeroes, under Trailing zeroes in Dimensions, select Show.
                    3. In Tolerances, select:

                       

                      ShowTo display trailing zeroes up to the number of decimal places applied to each tolerance within the dimension (Bilateral, Limit, and symmetric).
                      RemoveTo remove trailing zeroes from each tolerance (Bilateral, Limit, and symmetric).
                      Remove only on zeroTo remove trailing zeroes from each tolerance when the displayed value is zero. Also, when the value of the displayed tolerance is not equal to zero, trailing zeroes are displayed up to the number of decimal places that apply to each tolerance in the dimension.

                       

                    4. Click OK.

                    So it is fixed.