4 Replies Latest reply on Aug 1, 2018 6:27 PM by Paul Salvador

    Open Large .STP File

    Noah Jackowitz

      I'm trying to open a large .stp file (.65 GB), and SolidWorks 2018 seems to hit a wall trying to open it. I have task manager open and it shows the RAM leveling off around 10 GB (out of 32), and the CPU keeps churning at about 90% but the part loads indefinitely. It's been working for over 30 minutes. I've rebooted the computer, changed the sldimport.exe process to high priority, and tried B-Rep mapping but it's still hitting a wall. Is there any way to handle such a large file?

        • Re: Open Large .STP File
          Frank Krockenberger

          did you try and load it from your hard drive?

          • Re: Open Large .STP File
            Scott Boerman

            650MB will be a slow loading file for sure - I would expect maybe 1 hour load time direct.  Here's a few options:

            1) load from SSD (not sure if this matters, but surely does not hurt)

            2) upload it to grabcad, then download as a parasolid.  parasolids seem to load in 10-25% of the time of step files

            3) download Tera 4d trial version, open the step in Tetra4D, then export to parasolid an bring into SW.

             

            Sorry to say this, but if all of the content in the 650MB file is needed to be in a SW file, it may be unusably slow.  If/when the file gets opened in SW, it will be a very slow file to save and working with it may be impracticable/impossible.  Hopefully the file can be substantially minimized and a mini-copy used for moving forward.

             

            Another factor is if it's being opened with 3D interconnect  (2018 only, if I recall) on or off.  The file will look/behave differently with it turned on or off, which may or may not impact file usability.  (frustrating point, but thought to mention it nevertheless)

             

            Hope it goes well for you.

            • Re: Open Large .STP File
              Paul Salvador

              Hello Noah,.. something that large could take hours,.. suggest you to load it overnight.

              ..if you want to speed it up,.. you could disable the diagnostics/healing and entity/repair errors?