4 Replies Latest reply on Oct 18, 2018 8:02 PM by Paul Salvador

    Tracing before selecting surface

    Samuel Roberts

           So I ran into this problem, not a major one but a small annoying one. Every time i go to select a surface of any thing (assembly, part, plane) solidworks feels the need to trace it then select it. There has to be a fix to this time consuming process. And yes I have a good graphics card. It is an Intel(R) UHD Graphics 620, it is perfectly capable of running 3d renders. I have tried updating the driver and rolling back the driver as well.

        • Re: Tracing before selecting surface
          Shaodun Lin

          Hi Samuel

           

          I don't think Intel(R) UHD Graphics 620 is a certified card for SOLIDWORKS.

          Please see this:

          Graphics Card Drivers | Hardware & System Requirements | SOLIDWORKS

          2018-07-08_22-10-30.jpg

          • Re: Tracing before selecting surface
            Paul Salvador

            Hello Samuel,.. so, when you are in the System Options, do you have a "Use software OpenGL" (see attached)

            ..or try and set you Display Selection options as shown..(see attached)

             

            ..otherwise,.. I would do a Repair/Reinstall of SW... or delete the SW registry.. .and lastly, the OS (or try another graphics drivers (make sure it's a clean uninstall/reinstall) as a last chance effort?)

            openglz.pnghighlightx.png

              • Re: Tracing before selecting surface
                Arthur Vieira

                I have the same question essentially. I have a Dell Latitude 7390 with Intel(R) UHD Graphics 620 and the outline drawing (orange lines in my Solidworks 2015) when hovering a face or feature is very slow to draw. This makes working with Solidworks very hard. This is a work computer with quite high specs. Do I really have no option but ask my university department to try to buy a new PC just because Solidworks?


                Also, in my options "Use software OpenGL" option is grayed out and ticked, as shown below and the other two options that you mention, regarding highlighting, are also the same as you show, with Anti-aliasing off as well.

                 

                OpenGLpng.png

                 

                Beyond this, I've tried messing with the registry according to some online instructions. Under 'HKEY_CURRENT_USER > Software > Solidworks > SOLIDWORKS 2015 > Performance > Graphics > Hardware > Intel > Intel(R) UHD Graphics 620' (I created a folder for my graphics card), I create a key 'DWORD (32-bit) Value' named "Workarounds" with value "10000009". This seems to render the outline faster, but then I can't see the sketches. This makes me feel like there is a solution but for some reason Solidworks doesn't like this graphics card.

                 

                Any ideas?