25 Replies Latest reply on Jul 25, 2018 7:00 AM by Peter De Vlieger

    ecourses broken

    Cole Pearson

      I'm trying to take advantage of free online eCourses but they keep freezing in the middle of a lesson. Extremely frustrating. Anyone else experiencing this?

        • Re: ecourses broken
          Maha Nadarasa

          There are many online tutorials I do not know which course you say.

          • Re: ecourses broken
            Rob Edwards

            yes same here.

            intermittent audio, blank screens, constantly having refresh and log in..  I gave up

            • Re: ecourses broken
              Craig Girvan

              I've also had a few eCourses (API and PDM API) freeze a lot where it wont load the next page and I then have to refresh the page witch seems to sign me out so I have to log back in then click the option to resume where I last left off, hope that this option 'worked' then watch/skip the page that I already watched and then maybe continue to the next page or section.

               

              I've tried Edge, Chrome and Firefox as Browsers - Chrome seemed to load more consistently but often had no audio, while Edge would have the issue mentioned above and Firefox would sometimes not load the page and give some random error.

               

              Some other eCourses I've done in the past worked a lot better but still had the odd issue.

               

              Hopefully these issues can be resolved soon

               

              Craig

              • Re: ecourses broken
                Stavros Smith

                I had the same issue, I was using chrome and it would log me out every x minutes. Try using explorer, it solved the problem for me.

                • Re: ecourses broken
                  Joe Rousseau

                  Thank you very much for your interest in the eCourses hosted at MySolidWorks.com and for taking the time to share your experience. We are actively investigating these performance issues. In the meantime, we are adding a banner to MySolidWorks to advise customers that performance is currently impacted due to high demand.

                   

                  Best regards,

                  Joe Rousseau

                  SOLIDWORKS Training Manager

                    • Re: ecourses broken
                      Matt Peneguy

                      I guess those limited time free ecourses are much more popular than Dassault anticipated! That's a good thing, BTW.  I was going to look into it this weekend.  But, I think I'll wait until y'all get it sorted out.

                      • Re: ecourses broken
                        Peter De Vlieger

                        Perhaps you could also have someone look into the fact that the link for it mentioning it reverts back to the same page

                        Technical Alerts & News | SOLIDWORKS

                         

                        not exactly helpful

                          • Re: ecourses broken
                            Peter De Vlieger

                            @Joe Rousseau

                             

                            Even if I was the only one that noticed it, which in it self is kind of sad and tells a lot about quality control, 3 weeks after I mentioned that the link that is provided to get to the eCourse doesn't take you to the eCourse or even MySolidworks mainpage but simply reloads the Technical Alerts & news page it still does that. I even clearly show that the link indeed is circular (follow the red arrow in my screenshot) and it's not a browser issue.

                             

                            It's when little things like this go unnoticed and uncorrected that rub me the wrong way. Anyone with access to the HTML code could easily fix that in less time then it took me to report it the first time, let alone this follow up message.

                            But nobody cares.

                             

                            If it wasn't meant to be a link to the actual place to find the eCourse then it shouldn't have been a link to begin with. Again, a simple edit of the HTML code.

                          • Re: ecourses broken
                            Wayne Matus

                            Please break up long lessons or let us bookmark so we can return to where we left off. I have the same issue as others. Internet Explorer does work best, but it still hangs sometimes. Normally at the worst time. One hour into a 90 minute lesson and the spinning wheel has been spinning for 30 minutes. Now I will have to watch the hour again and hope it does not hang again.

                              • Re: ecourses broken
                                Joe Rousseau

                                Hi Wayne,

                                Let me start by saying that it is unfortunate that it still hangs sometimes. The patch that was put out by MySolidWorks in early July has made the site much faster and greatly reduced the "login issue" mentioned earlier in this thread.

                                 

                                As far as watching the hour again, we publish the eCourses using Articulate Storyline with the "Prompt to resume" option selected when a user restarts a lesson. I tested in Chrome and Internet Explorer this morning and it works as expected in both browsers.

                                 

                                Here's my test. I started a lesson, went several screens into the lesson, then closed the browser. I restarted the browser, logged into MySolidWorks, and returned to the same eCourse and same lesson. Both times, I was asked if I would like to resume where I left off. When I clicked Yes, I was brought to the exact screen in the lesson where I left off when I exited the browser.

                                 

                                I believe that will help if you have to re-start a lesson.

                                 

                                Best regards,

                                Joe Rousseau

                                SOLIDWORKS Training Manager

                            • Re: ecourses broken
                              Jason Rupert

                              the visualize content has NEVER worked 4 me...I would really like to learn how to use it effectively

                                • Re: ecourses broken
                                  Bill Toft

                                  Yesterday I did my first free eCourse (File Management).

                                  I use FireFox and was having those same problems (audio would cut in and out, the Demonstration segments would not work, etc.

                                  THEN I tried Internet Explorer. PROBLEMS SOLVED!

                                   

                                  I did notice that the lessons would occasionally freeze, but that was after an hour or so, and could be related to high user volume.

                                  I put the course in MyTraining so, after restarting IE, I was able to pick up where I left off.

                                   

                                  I am really impressed by the way they put the course together, especially the "now try it yourself" segments. As a long time user I thought this would just be a refresher course, but even though 90% was old news, there was 10% that contained valuable nuggets & new (to me)  techniques.

                                • Re: ecourses broken
                                  Eli Mather

                                  Thanks everyone for your interest in the eCourses on MySolidWorks.

                                   

                                  A patch has been released, please let us know if this improves your experience.

                                   

                                  Eli Mather

                                  MySolidWorks Product Management

                                    • Re: ecourses broken
                                      Bill Toft

                                      Eli,

                                      Thanks for that patch. It really seems to help.

                                      Yesterday I had trouble with Firefox, so today I decided to use Firefox on the Surfacing course. All went well. No delays and the first Demonstration module started and ran fine. BUT, after a few minutes (trim surface > rotate view) the sound disappeared. Same problem as yesterday with sound cutting out.

                                       

                                      So I went back to trusty Internet Explorer and started the course over again. This time the sound was fine all the way through that Demonstration.

                                       

                                      So I am not sure why IE works well consistently but not Firefox?

                                        • Re: ecourses broken
                                          Bill Toft

                                          I am now back to using Firefox (on Windows 7) to do the Surfacing eCourse.

                                          I logged a ticket with my VAR and this is from their reply:

                                          "Different customers have reported different levels of success across a wide range of browsers. This is likely due to Flash being enabled or disabled, which forces the eCourse to play in HTML5 mode. Also, users may have different add-ins and extensions enabled for different browsers that may affect playback performance and behavior."

                                           

                                          So, BE SURE YOU HAVE FLASH ENABLED in your browser!

                                           

                                          One consistent problem with Firefox (with Flash enabled) is that the demonstration videos will lose the audio part way through.

                                          My workaround is to pause the video just after it starts. Then RELOAD the browser tab. I get the prompt "Do you want to resume where you left off? and say yes. Now the video plays though to the end with audio.

                                           

                                          This is consistent behaviour. As log as I refresh the browse tab just after the video starts, the audio stays on (no matter how long the video runs.

                                            • Re: ecourses broken
                                              Matt Peneguy

                                              Bill Toft wrote:

                                               

                                              I am now back to using Firefox (on Windows 7) to do the Surfacing eCourse.

                                              I logged a ticket with my VAR and this is from their reply:

                                              "Different customers have reported different levels of success across a wide range of browsers. This is likely due to Flash being enabled or disabled, which forces the eCourse to play in HTML5 mode. Also, users may have different add-ins and extensions enabled for different browsers that may affect playback performance and behavior."

                                               

                                              So, BE SURE YOU HAVE FLASH ENABLED in your browser!

                                               

                                              I guess I won't be completing any of those ecourses after all.  I get the same thing from my VAR about viewing their videos on their website.  I refuse to install Flash or any other Adobe product.  They have a very bad record as far as security goes and I'm not opening my computers up to those problems.

                                              Why does anyone still use Flash?

                                        • Re: ecourses broken
                                          Joe Rousseau

                                          As Eli Mather noted, a patch was released in early July that improved performance and relieved the logout issue.

                                           

                                          Today, we released an update to the File Management eCourse. Using the latest version of Articulate Storyline 3, the updated eCourse improves the HTML5 output in the following ways:

                                          • Enhanced image clarity
                                          • Improved playback performance
                                          • Improved user experience in the "Try It" mode. Double-click and right-click work as expected. The "Please try again" message still appears, but the "Try It" moves onto the next user action.

                                           

                                          Please let us know your feedback. Do you see an improvement in the File Management eCourse?

                                           

                                          Best regards,

                                          Joe Rousseau

                                          SOLIDWORKS Training Manager