16 Replies Latest reply on Jun 18, 2018 3:29 PM by Kelvin Lamport

    Views don't look right

    Mike Hodson

      All of these views are 'Hidden lines visible'.  

       

      Hidden lines.JPG

       

      Why can't this be easy?

        • Re: Views don't look right
          John Pesaturo

          Mike, I can't disagree with your assessment. Those views certainly don't look correct. Hard to ascertain the cause from the screenshot but if there was any way you could post up a generic drawing and model I'm sure there are plenty of people who could track down the cause if it's setting related.

           

          Barring any issues related to settings the only other questions that will come up would be if you've verified your current graphics card is certified and running the appropriate driver.

          • Re: Views don't look right
            Tom Gagnon

            Per view, are tangent edges visible?

            Even so, it wouldn't explain bottom edges showing hidden, and top ones not visible, in the upper right view.

             

            Are all views ticked as High Quality (or same, by inheriting parent setting)? I have issues with hidden edges shown if it is degraded to draft quality, which sometimes happens when the sheet is not active when saving sometime in the past. I poke through every view on every sheet to confirm this before rendering to PDF for release. However, this drawing looks like it could be a single-sheet demonstration of the issue, not a part of a larger sheet set. It's hard to tell from just an image.

              • Re: Views don't look right
                Mike Hodson

                Thanks Tom.

                 

                All views have high quality ticked.  I never use draft quality.

                 

                Changing the view to 'Tangent edges visible' did make the views look as expected.  Although, this give the channel 4 hidden lines on either side, which is less than ideal. 

                  • Re: Views don't look right
                    Tom Gagnon

                    I never intend to use draft quality either, but sometimes it gets saved that way in multi-sheet large drawings of large assemblies. That was basis of my question. All same, it doesn't apply in this case.

                     

                    I turn off Tangent edges visible because I agree it appears too dense to be meaningful, particularly at a much smaller scale. Removing them, however, makes it appear without any extra horizontal lines, which makes it appear as a plate / tube. I got used to it, and it hasn't confused my welders or assemblers because we provide them extra views like Isometric to communicate a fuller understanding.

                     

                    Until you replace vid card with supported, this won't be the only unexpected result. Sorry to hear you're in that position. (Probably, only..) If it impacts production, then perhaps a decision can be expedited to fix that.

                • Re: Views don't look right
                  Kevin Chandler

                  Hello,

                   

                  I couldn't replicate it:

                   

                  Where does your channel come from?

                  I created mine from the structural steel toolbox.

                   

                  Are there configs here? Try Ctrl+Shift_Q?

                   

                  Cheers,

                   

                  Kevin

                    • Re: Views don't look right
                      Mike Hodson

                      They are the standard ANSI Inch weldment profiles from SW.  

                       

                      I can get them to look like yours, by selecting the view and choosing 'tangent lines visible'.   But even when tangent lines aren't visible, the hidden view should still give a hidden line for channel flanges. 

                    • Re: Views don't look right
                      Alex Lachance

                      Hey Mike,

                       

                       

                      From your screenshot, my guess is your 10 inch profile has tangent edges in the top part of the sketch while the bottom one doesn't.

                      On your 8 inch profile, both seem to be tangent, which would mean the display is correct.

                       

                      I hate how SolidWorks deals with profiles like this because of all the tangencies. Basically it will not show any hidden lines because of all the tangent segments. So unless you turn on the display of tangent edges, which brings in too many edges most of the time, you end up with a square without hidden lines.

                       

                      It would be great if SolidWorks would find a way to allow us to modify the way it displays these profiles. Something along the line of having the default settings and something that would override one's setting to use a user intended display. I hate having to show all tengent lines to then hide the ones I don't need. Generally, this is what it displays. In red is the undesired lines, in blue the one I use right now.

                       

                      It would be great if I could override this and tell it to display one of the following or even any:

                       

                      Unfortunately, it would be very hard to program this because the wedlments can have so many custom shapes, I'm not sure how a programmer would approach this.

                        • Re: Views don't look right
                          Tom Gagnon

                          You can do this by editing the weldment profile and deleting a tangent relation from a tangent arc. That will "score" your views with a line where you want it, by making a previously tangent edge non-tangent.

                          • Re: Views don't look right
                            Mike Hodson

                            Thanks Alex.

                             

                            It seems that every working day, I find my self saying

                            "I hate how SolidWorks deals with____________"

                             

                            I still have and use Inventor on my workstation.    I prefer Solidworks for modeling, but I've come to realize that Inventor is so much easier when it comes to drawings and dimensioning.

                              • Re: Views don't look right
                                Alex Lachance

                                The only reason we hate how SolidWorks deals with something is because we have something else to base ourself of that we are generally used to.

                                 

                                Changing from one program to another program, it is common behavior to be comparing programs and wondering why one doesn't work like the other one does. When you take a step back from all the frustration, the explanations are generally simple and pretty logical, even tough sometimes they still leave us at awe

                                 

                                I think what Tom suggested here would be right for you. SolidWorks simplifies a lot of stuff for us so we expect it to match other programs. As I said, it cannot work that way for different reasons, one of it being the programming of the program.

                                 

                                In this case, it is easier to fool the program into thinking it is not a tangent segment then it is to teach the program about how to deal with different tangent profiles and edges.

                                 

                                I think that is the best way to explain it

                            • Re: Views don't look right
                              Dennis Dohogne

                              Mike, go into the System settings (with no SWX files open) and then go to Performance and check the box near the bottom for "Use software OpenGL" then open your drawing.

                              If the image appears correct including the hidden lines then it means your video card is the culprit.  If the problem persists then there is something else going on.