10 Replies Latest reply on Jun 5, 2018 9:25 AM by Al Griego

    Solidworks Not Working Properly after Windows Update or Whatever it is.

    Ivan Ho

      My Solidworks 2017 running on a GeForce MX150 graphics card is encountering issues with dimensioning in drawing files and part files and other performance issues.  I think things started going really bad after a windows update yesterday. I was unable to dimension in new part files and drawing files. The weird thing is that I can still dimension perfectly well on files that I've saved earlier. I have already reset all settings under tools>options. I've played around with the open GL box under tools>options>performance, it only made matters worse as performance was very slow after it's checked.

       

      I did a system restore to before the windows 10 update and I think it only solved the slow graphics performance issue (which I later figure it's because I've checked the open GL box). I still cannot do dimensioning on new part and new drawing files. I've also noticed that things get really slow if I show the planes and this "massive blue arrow" is blocking half of the model at all times.

       

      Screenshot 1.jpg

       

      I've also noticed that the Front, Right, Top plane labeling no longer show up on the corner of the planes.

       

      I've also went to the Registry Editor and renamed the Solidworks folder to Solidworks-OLD. This reset everything to when the software was installed. But it didn't seem to solve much of the problems above.

       

      I've taken the files to another computer with Solidworks 2017 (a desktop) and it worked perfectly fine and smooth.

       

      The software worked perfectly fine last week and the month before (when the computer is new) and now it's unusable. Hope someone here can help me.

       

      Ivan