25 Replies Latest reply on May 31, 2018 9:52 AM by Josh Brady

    The orientation command is not working.

    ömür tokman

      Hi, have a nice day.

      The orientation command is not working.

      When I press the Space Bar button, the Orientation window does not open.

      Button always appears active.

      Is there a solution?

      Is it necessary to remove and reinstall SW

       

      2018-05-29_16-16-19.png

        • Re: The orientation command is not working.
          Tony Tieuli

          ömür tokman wrote:

           

          Hi, have a nice day.

          The orientation command is not working.

          When I press the Space Bar button, the Orientation window does not open.

          Button always appears active.

          Is there a solution?

          Is it necessary to remove and reinstall SW

           

          2018-05-29_16-16-19.png

          It may be that your orientation dialog box is off screen.

          Hit the spacebar first so that the orientation dialog box should be  displayed. Then:

          From another thread, all credit to Josh Brady.

          Hit Alt, then Space, then M (not holding down, just hit 'em).  Then hit an arrow key.  That will put the dialog into "move it around" mode, and you can then move your mouse around (don't click, just move the mouse) until you see the dialog.

           

          Hope this helps.!

           

          EDIT:

          For the orientation dialog you need to hold down ALT-Spacebar. The windows move dialog box will come up. Release ALT-Spacebar then it works as outlined above.

            • Re: The orientation command is not working.
              ömür tokman

              Bu pencere benim bilgisayarımda açılmıyor.

              boşluk veya "ctrl + space + m" bu pencereyi açmadı

               

              bu görüntü benim bilgisayarıma ait değil

              Adsız.jpg

              my pc

              2018-05-29_18-29-03.png

                • Re: The orientation command is not working.
                  Dan Pihlaja

                  As Tony Tieuli  said, it is probably off screen.

                  You mentioned "CTRL SPACE M".   That isn't what Tony was referring to.

                  Tony was referring to "ALT SPACE M", which is a specific windows (NOT SOLIDWORKS) command that brings up the ability to move a window around with the arrow keys.

                  So, after you hit "ALT SPACE M", then use the arrow keys to see if you can get it to appear on screen.

                   

                  ______________________________________________

                  Translated:

                  Tony Tieuli'nin dediği gibi, muhtemelen ekran dışı.
                  "CTRL SPACE M" den bahsettin. Tony'nin bahsettiği şey bu değildi.
                  Tony, bir pencereyi ok tuşlarıyla hareket ettirme özelliğine sahip belirli bir penceredir (SOLIDWORKS DEĞİL) olan "ALT SPACE M" ye atıfta bulundu.
                  Yani, "ALT SPACE M" ye bastıktan sonra, ekranda görünmesini sağlayabilmek için ok tuşlarını kullanın.

                    • Re: The orientation command is not working.
                      Kevin Chandler

                      Dan Pihlaja wrote:

                       

                      As Tony Tieuli said, it is probably off screen.

                      You mentioned "CTRL SPACE M". That isn't what Tony was referring to.

                      Tony was referring to "ALT SPACE M", which is a specific windows (NOT SOLIDWORKS) command that brings up the ability to move a window around with the arrow keys.

                      So, after you hit "ALT SPACE M", then use the arrow keys to see if you can get it to appear on screen.

                       

                      A small point: it's ALT+SPACE (both pressed at the same time) to display this menu:

                      Then release these keys and type an M for "Move" (it may be a different underlined letter in your language, try this on a window you can see to test which you need to press for your Windows installation).

                      Pressing and releasing ALT before pressing SPACE doesn't display this menu.

                       

                      Cheers,

                       

                      Kevin

                        • Re: The orientation command is not working.
                          Dan Pihlaja

                          Kevin Chandler wrote:

                           

                          Dan Pihlaja wrote:

                           

                          As Tony Tieuli said, it is probably off screen.

                          You mentioned "CTRL SPACE M". That isn't what Tony was referring to.

                          Tony was referring to "ALT SPACE M", which is a specific windows (NOT SOLIDWORKS) command that brings up the ability to move a window around with the arrow keys.

                          So, after you hit "ALT SPACE M", then use the arrow keys to see if you can get it to appear on screen.

                           

                          A small point: it's ALT+SPACE (both pressed at the same time) to display this menu:

                          Then release these keys and type an M for "Move" (it may be a different underlined letter in your language, try this on a window you can see to test which you need to press for your Windows installation).

                          Pressing and releasing ALT before pressing SPACE doesn't display this menu.

                           

                          Cheers,

                           

                          Kevin

                           

                          You are correct....specifically for Solidworks I guess....All other windows programs, you can tap the ALT, then tap the SPACE.

                            • Re: The orientation command is not working.
                              Josh Brady

                              Dan Pihlaja wrote:

                               

                               

                               

                              You are correct....specifically for Solidworks I guess....All other windows programs, you can tap the ALT, then tap the SPACE.

                               

                              It's even case-by-case within SW.  Mass Properties and Measure, for example, don't require holding down ALT.  The Orientation Dialog apparently does.  The shortcut doesn't even work at all for the Equation dialog (on my machine anyway).

                      • Re: The orientation command is not working.
                        Kevin Chandler

                        Tony Tieuli wrote:

                         

                        ömür tokman wrote:

                         

                        Hi, have a nice day.

                        The orientation command is not working.

                        When I press the Space Bar button, the Orientation window does not open.

                        Button always appears active.

                        Is there a solution?

                        Is it necessary to remove and reinstall SW

                         

                        2018-05-29_16-16-19.png

                        It may be that your orientation dialog box is off screen.

                        Hit the spacebar first so that the orientation dialog box should be displayed. Then:

                        From another thread, all credit to Josh Brady.

                        Hit Alt, then Space, then M (not holding down, just hit 'em). Then hit an arrow key. That will put the dialog into "move it around" mode, and you can then move your mouse around (don't click, just move the mouse) until you see the dialog.

                         

                        Hope this helps.!

                        If the dialog box is pinned, these steps will not work to move the dialog.

                        It will remain wherever it is until it's dragged by the mouse or it's unpinned and then Mr. Tieuli's suggestion will work fine.

                        But to unpin it (if it's pinned), you must locate it.

                         

                        Also, this dialog box can be positioned outside of the SW main window, so look around everywhere and under any open windows.

                         

                        Cheers,

                         

                        Kevin

                          • Re: The orientation command is not working.
                            Josh Brady

                            Kevin Chandler wrote:

                             

                             

                            If the dialog box is pinned, these steps will not work to move the dialog.

                            It will remain wherever it is until it's dragged by the mouse or it's unpinned and then Mr. Tieuli's suggestion will work fine.

                            But to unpin it (if it's pinned), you must locate it.

                             

                            Also, this dialog box can be positioned outside of the SW main window, so look around everywhere and under any open windows.

                             

                            Cheers,

                             

                            Kevin

                             

                            In 2016 and 2017 it works just fine, regardless of pinning state.

                             

                            Perhaps you could try alt-space-s for "size"... then hit an arrow key (don't forget to hit the arrow key) and you can resize the dialog with the mouse.  Note that it will only resize to the direction that you hit the arrow key.  so if you hit right arrow, but the box is on the right, you won't be able to size it back to the left screen.

                          • Re: The orientation command is not working.
                            Habib Ghalamkari

                            Tony Tieuli wrote:

                             

                            It may be that your orientation dialog box is off screen.

                            Hit the spacebar first so that the orientation dialog box should be displayed. Then:

                            From another thread, all credit to Josh Brady.

                            Hit Alt, then Space, then M (not holding down, just hit 'em). Then hit an arrow key. That will put the dialog into "move it around" mode, and you can then move your mouse around (don't click, just move the mouse) until you see the dialog.

                             

                            Hope this helps.!

                            Tony, as far as I know, orientation window is not a stand alone window. and can not be moved by windows default short cuts.
                            Can you move it on your screen with these shortcuts?

                              • Re: The orientation command is not working.
                                Josh Brady

                                Did you give it a shot, or did you just pooh-pooh it from afar?

                                 

                                For the measure dialog, the method Tony posted works.  You don't have to hold down Alt.

                                 

                                For the Orientation Window, you actually have to hold down Alt while you press Space to get the standard dropdown. From there you can hit M for Move.

                                 

                                Here comes the tricky part... If you don't have the View Selector activated,  (it's the toggle button at the top right of the Orientation window), then the shortcuts work as expected.  If it IS activated, when you hit M the cursor briefly flashes to the "move dialog" cursor, but then the whole thing just disappears.  Bummer.  But, you can toggle the view selector with Ctrl+spacebar.  So, open the Orientation Window, and if that dumb cube thing appears on your screen, hit Ctrl-space to make it go away.  Then you can hit Alt-Space and M and then move the dang winder where you want it.

                                 

                                YMMV.  As I said, 2017 sp2.  Also same behavior on 2016 sp4.

                                  • Re: The orientation command is not working.
                                    Habib Ghalamkari

                                    Josh Brady wrote:

                                     

                                    Did you give it a shot, or did you just pooh-pooh it from afar?

                                     

                                    Probably a bug, maybe fixed already... Here I have only 2017 sp2...

                                     

                                    For the measure dialog, the method Tony posted works. You don't have to hold down Alt.

                                     

                                    For the Orientation Window, you actually have to hold down Alt while you press Space to get the standard dropdown. From there you can hit M for Move.

                                     

                                    Unless (here comes the bug) you have that fancy-schmancy "cube plane selector" thingy active. If that's not activated, (it's the toggle button at the top right of the Orientation window), then the shortcuts work as expected. If it IS activated, when you hit M the cursor briefly flashes to the "move dialog" cursor, but then the whole thing just disappears.

                                     

                                    YMMV. As I said, 2017 sp2. Also same behavior on 2016 sp4.

                                    No, I didn't just pooh-pooh it from afar. I tested it.

                                    No matter holding all the keys or press them simultaneously one after another, it doesn't work.

                                      • Re: The orientation command is not working.
                                        Tony Tieuli

                                        Habib Ghalamkari wrote:

                                         

                                        Josh Brady wrote:

                                         

                                        Did you give it a shot, or did you just pooh-pooh it from afar?

                                         

                                        Probably a bug, maybe fixed already... Here I have only 2017 sp2...

                                         

                                        For the measure dialog, the method Tony posted works. You don't have to hold down Alt.

                                         

                                        For the Orientation Window, you actually have to hold down Alt while you press Space to get the standard dropdown. From there you can hit M for Move.

                                         

                                        Unless (here comes the bug) you have that fancy-schmancy "cube plane selector" thingy active. If that's not activated, (it's the toggle button at the top right of the Orientation window), then the shortcuts work as expected. If it IS activated, when you hit M the cursor briefly flashes to the "move dialog" cursor, but then the whole thing just disappears.

                                         

                                        YMMV. As I said, 2017 sp2. Also same behavior on 2016 sp4.

                                        No, I didn't just pooh-pooh it from afar. I tested it.

                                        No matter holding all the keys or press them simultaneously one after another, it doesn't work.

                                        Sorry, I have to disagree. I have it up on my screen right now and it's working just the way Josh Brady says.

                                        I was unaware that the ALT space M sequence I quoted in my original reply didn't work for the orientation dialog. But holding down ALT and Space simultaneously to get the drop down, release ALT-space then press the M key, use one of the arrow keys then the mouse does work. I just did it.

                                          • Re: The orientation command is not working.
                                            Habib Ghalamkari

                                            Tony Tieuli wrote:

                                            Sorry, I have to disagree. I have it up on my screen right now and it's working just the way Josh Brady says.

                                            I was unaware that the ALT space M sequence I quoted in my original reply didn't work for the orientation dialog. But holding down ALT and Space simultaneously to get the drop down, release ALT-space then press the M key, use one of the arrow keys then the mouse does work. I just did it.

                                            I’m away from my desk Now. I‘ll follow your steps as soon as I’m back to work.

                                             

                                            thank you

                                      • Re: The orientation command is not working.
                                        Josh Brady

                                        Habib Ghalamkari wrote:

                                         

                                        Tony Tieuli wrote:

                                         

                                        It may be that your orientation dialog box is off screen.

                                        Hit the spacebar first so that the orientation dialog box should be displayed. Then:

                                        From another thread, all credit to Josh Brady.

                                        Hit Alt, then Space, then M (not holding down, just hit 'em). Then hit an arrow key. That will put the dialog into "move it around" mode, and you can then move your mouse around (don't click, just move the mouse) until you see the dialog.

                                         

                                        Hope this helps.!

                                        Tony, as far as I know, orientation window is not a stand alone window. and can not be moved by windows default short cuts.
                                        Can you move it on your screen with these shortcuts?

                                        So... I just got on SW2018 sp3.0.  It seems that at some point SolidWorks decided to map a default shortcut for "Take Snapshot" to Alt-Spacebar.  That was a terrible thing to do. The SolidWorks shortcut blocks the Windows hotkey functionality.

                                         

                                        To fix this, go to Tools->Customize, Keyboard tab, and search for "snapshot".  Delete the Alt-Spacebar shortcut.

                                          • Re: The orientation command is not working.
                                            ömür tokman

                                            Yes

                                            You are right , I am now delete (not to happen again)

                                            thank you.

                                            • Re: The orientation command is not working.
                                              Tony Tieuli

                                              Josh Brady wrote:

                                               

                                              Habib Ghalamkari wrote:

                                               

                                              Tony Tieuli wrote:

                                               

                                              It may be that your orientation dialog box is off screen.

                                              Hit the spacebar first so that the orientation dialog box should be displayed. Then:

                                              From another thread, all credit to Josh Brady.

                                              Hit Alt, then Space, then M (not holding down, just hit 'em). Then hit an arrow key. That will put the dialog into "move it around" mode, and you can then move your mouse around (don't click, just move the mouse) until you see the dialog.

                                               

                                              Hope this helps.!

                                              Tony, as far as I know, orientation window is not a stand alone window. and can not be moved by windows default short cuts.
                                              Can you move it on your screen with these shortcuts?

                                              So... I just got on SW2018 sp3.0. It seems that at some point SolidWorks decided to map a default shortcut for "Take Snapshot" to Alt-Spacebar. That was a terrible thing to do. The SolidWorks shortcut blocks the Windows hotkey functionality.

                                               

                                              To fix this, go to Tools->Customize, Keyboard tab, and search for "snapshot". Delete the Alt-Spacebar shortcut.

                                              I'm on 2018 3.0 and alt-spacebar works for me.

                                              I searched for snapshot under the Customize keyboard and it's not even there. I also tried take snapshot. That's not there either.

                                               

                                              Cue the Twilight Zone theme.

                                                • Re: The orientation command is not working.
                                                  Kevin Chandler

                                                  Tony Tieuli wrote:

                                                   

                                                  Josh Brady wrote:

                                                   

                                                  Habib Ghalamkari wrote:

                                                   

                                                  Tony Tieuli wrote:

                                                   

                                                  It may be that your orientation dialog box is off screen.

                                                  Hit the spacebar first so that the orientation dialog box should be displayed. Then:

                                                  From another thread, all credit to Josh Brady.

                                                  Hit Alt, then Space, then M (not holding down, just hit 'em). Then hit an arrow key. That will put the dialog into "move it around" mode, and you can then move your mouse around (don't click, just move the mouse) until you see the dialog.

                                                   

                                                  Hope this helps.!

                                                  Tony, as far as I know, orientation window is not a stand alone window. and can not be moved by windows default short cuts.
                                                  Can you move it on your screen with these shortcuts?

                                                  So... I just got on SW2018 sp3.0. It seems that at some point SolidWorks decided to map a default shortcut for "Take Snapshot" to Alt-Spacebar. That was a terrible thing to do. The SolidWorks shortcut blocks the Windows hotkey functionality.

                                                   

                                                  To fix this, go to Tools->Customize, Keyboard tab, and search for "snapshot". Delete the Alt-Spacebar shortcut.

                                                  I'm on 2018 3.0 and alt-spacebar works for me.

                                                  I searched for snapshot under the Customize keyboard and it's not even there. I also tried take snapshot. That's not there either.

                                                   

                                                  Cue the Twilight Zone theme.

                                                  Is this what you're looking for?

                                                    • Re: The orientation command is not working.
                                                      Josh Brady

                                                      Kevin Chandler wrote:

                                                       

                                                      Is this what you're looking for?

                                                       

                                                      Nope... That ain't it.  I wonder if it's part of an add-in.  Although I just disabled every add-in and restarted SW.  It's still there.

                                                       

                                                       

                                                      Also shows up in my Command Search thingy:

                                                        • Re: The orientation command is not working.
                                                          Tony Tieuli

                                                          Josh Brady wrote:

                                                           

                                                          Kevin Chandler wrote:

                                                           

                                                          Is this what you're looking for?

                                                           

                                                          Nope... That ain't it. I wonder if it's part of an add-in. Although I just disabled every add-in and restarted SW. It's still there.

                                                           

                                                           

                                                          Also shows up in my Command Search thingy:

                                                          Wow, that's strange. It doesn't show up under my command search thingy either.

                                                        • Re: The orientation command is not working.
                                                          Tony Tieuli

                                                          Kevin Chandler wrote:

                                                           

                                                          Tony Tieuli wrote:

                                                           

                                                          Josh Brady wrote:

                                                           

                                                          Habib Ghalamkari wrote:

                                                           

                                                          Tony Tieuli wrote:

                                                           

                                                          It may be that your orientation dialog box is off screen.

                                                          Hit the spacebar first so that the orientation dialog box should be displayed. Then:

                                                          From another thread, all credit to Josh Brady.

                                                          Hit Alt, then Space, then M (not holding down, just hit 'em). Then hit an arrow key. That will put the dialog into "move it around" mode, and you can then move your mouse around (don't click, just move the mouse) until you see the dialog.

                                                           

                                                          Hope this helps.!

                                                          Tony, as far as I know, orientation window is not a stand alone window. and can not be moved by windows default short cuts.
                                                          Can you move it on your screen with these shortcuts?

                                                          So... I just got on SW2018 sp3.0. It seems that at some point SolidWorks decided to map a default shortcut for "Take Snapshot" to Alt-Spacebar. That was a terrible thing to do. The SolidWorks shortcut blocks the Windows hotkey functionality.

                                                           

                                                          To fix this, go to Tools->Customize, Keyboard tab, and search for "snapshot". Delete the Alt-Spacebar shortcut.

                                                          I'm on 2018 3.0 and alt-spacebar works for me.

                                                          I searched for snapshot under the Customize keyboard and it's not even there. I also tried take snapshot. That's not there either.

                                                           

                                                          Cue the Twilight Zone theme.

                                                          Is this what you're looking for?

                                                          Not really looking for anything, just checking out Josh Brady's info above. Checked out yours as well. Mine is just like yours, no shortcut assigned.

                                                  • Re: The orientation command is not working.
                                                    ömür tokman

                                                    Thank you very much, Mr. Tony

                                                    thank you all

                                                     

                                                    quotation from Habib Ghalamkari

                                                    "Tony, as far as I know, orientation window is not a stand alone window. and can not be moved by windows default short cuts."

                                                    --Yes not moving--

                                                     

                                                    Everything turned out when I put on the second monitor.

                                                    1.jpg

                                                    I do not know english, I use to google translate, I apologize if there is a translation error.

                                                  • Re: The orientation command is not working.
                                                    Kevin Chandler

                                                    Hello,

                                                     

                                                    It could be that the Orientation dialog box is no longer mapped to the default keyboard shortcut of Spacebar.

                                                    This is SW2018, but since there is no text after "More Options" means that there's no keyboard shortcut assigned to display the Orientation dialog box.

                                                    Start Customize and go to Keyboard tab:

                                                    Click in the Shortcut(s) box and press the spacebar and click OK.

                                                    Now the shortcut is displayed:

                                                    With or without a shortcut, you can click on the ">>" button to display the Orientation dialog.

                                                     

                                                    Cheers,

                                                     

                                                    Kevin

                                                    • Re: The orientation command is not working.
                                                      Christian Chu

                                                      There is another alternative - Try this

                                                      • Re: The orientation command is not working.
                                                        ömür tokman

                                                        What matters to me, the clue you gave.

                                                        that's a good one

                                                        "It may be that your orientation dialog box is off screen."

                                                         

                                                        my goal! to be experienced like you.

                                                        Thank you again