4 Replies Latest reply on Nov 14, 2018 7:39 AM by L. T.

    When I access the materiel  library there is an error parameter incorrect....?????

    Renjith Nair

      Hi Friends,

      When I try to open the material library, getting an error "parameter is incorrect". When click OK it shows a blank white window. Please help me......

        • Re: When I access the materiel  library there is an error parameter incorrect....?????
          Adrian Czapla

          Hi Renjith,

          it is known issue connected with SOLIDWORKS Simulation licensing. As a temporary solution, turn off Simulation add-in.

          • Re: When I access the materiel  library there is an error parameter incorrect....?????
            Cad Admin

            I had the same issue.  Contacted my VAR. They stated it is a possible issue may be related to erroneous or incorrect subscription information within a SolidWorks Simulation license. A fix that has worked for some customers is to reactivate your license.

            This solution fixed my issue.

            • Re: When I access the materiel  library there is an error parameter incorrect....?????
              L. T.

              At a university environment, we ran across this issue just today. One reason for the vague 'parameter is incorrect' error message is because the license for SolidWorks that is checked out from a license server does not support Premium add-ons.

               

              In our case, the license server ordering by default was incorrect, so it was checking out a Solidworks standard license instead of a Solidworks Premium (or higher) license by default. The end user is able to fix this issue with the following steps:

               

              1) Click on the down arrow next to the help (?) icon on the top toolbar on the right hard corner,

               

              2) From the dropdown menu, select the SolidNetWork License Manager option.

               

              3) Navigate to the "License Order" tab and select the SOLIDWORKS Premium (or higher) license option.

               

              4) Click the "Move Up" button, until the SOLIDWORKS Premium (or higher) license option is at the top of the list.

               

              5) Click OK button, and exit SolidWorks.

               

              6) Re-open Solidworks.

               

              At this point, the correct license (not standard) should be checked out, and the Simulation add-on can be enabled and should work with no issues when attempting to create a custom material, or selecting a pre-made material.

               

              From this thread, I was able to figure out that the (custom) client license order lives in the HKCU hive:

              Client License Order

               

              Due to this, a fix is not trivial in our environment, as VMs are instantiated from a master image at every user logon. Can this license order be changed in the license manager? If so, how? Otherwise, if there is another way to fix this without having to write to the HKCU hive, that'd be ideal.