AnsweredAssumed Answered

Equations & Solidworks 2018 SP2.0

Question asked by Jack Brooker on May 10, 2018
Latest reply on May 15, 2018 by Matt Peneguy

Having a problem with equations in 2018, most likely nothing too surprising considering this is Solidworks i'm talking about.

 

At my company we use a block for our logo, the sizes of which are all tied to one overall dimension using equations, allowing it to scale everything properly when changed. We have used this block for several years going back throughout several versions of Solidworks, and for at least the past couple of years we have never had any problems like this with it.

Recently, after the SP2.0 update, some of our computers & their installs of Solidworks have decided to stop working with equations. Not only does the logo stop working, but all equations inside these Solidworks installs decide not to work. The settings across installs appear to be identical, i've tried changing the settings in the equations tool across both with no changes to the outcome. Force rebuilding the sketch/block has no effect, having it outside of the block changes nothing, i've contacted our reseller and we've both come to the conclusion that its likely best to either repair the install or just do it fresh.

 

I'm going to try this now and reply back later with results as to whether it has worked, but the problem itself seems to of come straight from SP2.0, and i'm wondering whether anybody else has also encountered this issue - and possibly found out the exact cause and/or proper solution?

Outcomes