5 Replies Latest reply on Apr 19, 2018 7:14 AM by Steven Moseley

    Model for flow simulation keeps getting stuck at "preparing model"

    Ahmed Sarwar

      Hi all,

       

      PC-Specs: 6-core 6th generation interl i7 processor, 128gb ram with a samsung ssd. Solidworks 2017

       

      I have been experiencing a very weird problem. My model contains 14 racks placed in a cabin. Each rack has 45 flat plates on it, which act as heat sources. I also have three fan profiles made with rotating regions, as well as cooling coils that act as heat sinks. The flow is internal. Attached is a general picture of the setup.

       

      This whole setup has been tested and simulated before. However, for the past few weeks, I have been trying to run the simulation, but I cant seem to get past the preparing model portion of the meshing. It doesn't give me an error, neither does it crash. The memory just stops fluctuating and it stays there for hours on end (12-14 hours).

       

      If I go back to the previous runs, and run them, they work fine, however, as soon as I make any changes, or move parts around, the problem appears. I have tried starting with a few racks, and then increasing their number, but it doesn't work as soon as I get to the whole system. I run the geometry check every time, and it does not give me any errors either.

       

      I have also gone back and redesigned all the original parts, but as soon as I try to mesh the whole cabin, the same problem appears. 

       

      Any helpful advice would be appreciated.

       

      Capture.PNG