19 Replies Latest reply on Jul 12, 2018 1:23 AM by Damir Galic

    Glitchy geometry

    Andreas Olofsson

      Has anyone else encountered this? How do I solve it? Been pulling my hair out trying to make it go away but to no avail. It's messing up my renders. Geometry looks normal within Solidworks 2017 but messed up in Visualize.

      I've tried using "repair normals" and "rebuild normals" or whatever, but that had no effect. I'm assuming it's related to the normals maybe?

       

       

      EDIT:

      Interesting... I tried exporting the geo from Visualize and imported it into Blender. Looks normal in there...

      untitled.png

        • Re: Glitchy geometry
          Rob Rodríguez

          What if you export the geometry out of blender and back into Vis?  Does that still give you the glitch results in Vis?

           

          I've had some weird issues the last couple of days but its overlapping geometry that vis is either importing hidden parts from SW or creating multiple "material" instances of the same parts in Vis.  I have found ways to solve it.

           

          Another thought.  What if you export your SW file as an OBJ and import that into Vis.  Do you still have the issue?

          If you do a google search for SW OBJ exporter you'll find a free one.  It works pretty well.

            • Re: Glitchy geometry
              Andreas Olofsson

              Hi Rob!

               

              Appreciate the input. I tried importing from Blender but the weird geo still showed up in Visualize

               

              I've also gotten an increase of this type of glitches the last week for some reason... In one case the fix was just to re-import the model and Visualize managed to interpret the geo properly the second time around.

               

              In this case though at first I assumed it was the classic case of Visualize importing hidden parts (how about a fix for this in a future SP, devs?), but there are no hidden parts in my assembly. I even imported the single part file and still get the glitch... Can't figure this one out!!

               

              Anyway, thanks again for the input!

            • Re: Glitchy geometry
              Shad Thomas

              Is the "ELME" decal placed in solidworks and then imported into Visualize? If so, try removing it before exporting to Visualize and then add it while in Visualize. I've had some issues with exporting decals from Solidworks into Visualize.

                • Re: Glitchy geometry
                  Andreas Olofsson

                  Hi Shad!

                  It's actually a "split line" feature and not a decal. I've personally got no faith in using decals for various reasons... So I just model my "decals" into the geometry.

                   

                  I tried importing the part without the split line feature, but the problem is still there on the rounded edges:

                  Areas with densely packed edges seem to be affected by this glitch. On this particular part... Very strange. I've had several parts modeled the same way but never had this problem before. I guess my best bet is having a dev have a look at the SW part and see what they can find.

                   

                  Thanks for your input!

                • Re: Glitchy geometry
                  Ron Bates

                  Andreas - I know in some of those screenshots, we see what looks like a single part, isolated from the rest of the assembly.  Did you just hide everything else?  OR did you import the part/component itself into an empty scene?  If it was the former, can you try the latter?  I'm just curious if the issue displays only when importing the assembly...or if it occurs when importing the part itself.

                   

                  Along with Rob's idea, use another native format from SW (instead of .OBJ.)  ie Export the part file as a parasolids .X_T or .X_B.  Then import this into visualize.  And again, check on the rebuild/repair normals options for the part.

                   

                  Also looks like, from your screenshots, you're on 2017.  Can/have you tried 2018?

                   

                  (note: regarding import of hidden geometry.  This issue is on our radar. It only occurs when importing using Appearance part grouping.  If you import using Automatic, then hidden geometry will be set to 0% opaque).

                    • Re: Glitchy geometry
                      Andreas Olofsson

                      Hi Ron,

                       

                      Thanks for the input! Much appreciated

                      The part was imported all by itself into an empty scene. This problem seems to be rooted in the part level and just gets more noticeable as the part moves up the hierarchy and assembly features like 'extruded cut' are introduced - since that adds more densely packed edges to the geo.

                      I've tried Visualize 2018 but I get the same results there. Tried saving as .X_T and .X_B but it looks the same Rebuild / repair normals had no effect either.

                       

                      Sending you a PM!

                       

                      Glad to hear there's something in the works for the Appearance importation of hidden parts btw There have been scenarios where I've received CAD data from a client and once it's in Visualize I can only trust that it'll look the same as it did for their engineer inside of SW.

                      On a side note I personally never use Automatic part grouping for big assemblies as applying box mapping and world scale to every part that needs it is a project in and of itself.

                    • Re: Glitchy geometry
                      Andreas Olofsson

                      Any progress on this issue? I've noticed this glitch is present in all my files and I need to re-render some stuff right now... Would be nice to not have messed up lines all over my products :O

                      I even saw this glitch in my miter saw contest entry...

                       

                      This issue must've surfaced somewhere between Visualize 2017/2018. I've got a file that was last saved back in 2016 and when I rendered it back then those lines weren't there. But now when I open it in 2018 there they are...

                       

                      Haven't seen anyone else mention they have the same issue so I suppose it's my specific HDRI and lighting that doesn't play well with Visualize 2018.

                        • Re: Glitchy geometry
                          Heiko Sohnholz

                          Hello Andreas,

                          maybe this is the same glitch, discussed in this another thread: SOLIDWORKS Visualize brushed appearances

                          There we could solve this problem with using a planar texture projection...

                          Cheers, Heiko

                          • Re: Glitchy geometry
                            Rob Rodríguez

                            I've seen similar issues on a recent project I've been working on.  I saved the SolidWorks files which showed the issue (not all files show the issue) as a stp file.  Opened that in Visualize and the geometry is perfectly fine.  I then add the stp file version geometry to my Visualize scene with the SolidWorks files that convert correctly.

                              • Re: Glitchy geometry
                                Andreas Olofsson

                                Very interesting, Rob! Glad I'm not the only one with this problem... :/

                                 

                                I'll give it a try, but I've got bad experiences with exporting an assembly as .stp from Solidworks... All the appearances get messed up and scattered

                                There's always something... Nothing's ever easy

                                  • Re: Glitchy geometry
                                    Rob Rodríguez

                                    I was just saving out a single part as a stp and replacing that geometry in my Vis project.  An entire assembly will be a challenge for material painting etc.  I did have pretty decent luck with obj export keeping the material painting from SolidWorks correct.  There is a macro that allows OBJ export from SW Free Solidworks OBJ Exporter v2.0

                                    • Re: Glitchy geometry
                                      Chris Dordoni

                                      The long, spikey triangles that the SolidWorks mesher produces appear to be related to the problem. I have occasionally broken up surfaces (project with line works, its not necessary to split the body) to force resulting triangles to be less acute.

                                       

                                      Unfortunately this is not a good work around in many cases. What is required is a mesher that can control the aspect ratio, and or subdivision, to produce triangle where the edges are closer to the same length.

                                        • Re: Glitchy geometry
                                          Steven McCallion

                                          I don't play with Visualise much, but it looks like a similar problem to what we run into with FEM stuff, and as Chris suggests a better mesher would probably help the situation. Here I doubt much attention is given to the meshing at all considering it's probably some form of bog standard stl translation going on in the background.

                                          I'd guess that a rounding error results in some of those triangles having normals pointing just slightly off enough that it's visually perceptable/the renderer is making it so.

                                          A solution would be to play around, as Chris has also suggested with split lines everywhere to tidy it up. And again, as he's also mentioned, not necesarily a solution in every instance.

                                           

                                          Some examples of a long plate with a small hole in it, then some split lines added to force the stl mesher to "behave".

                                          Part1aSW.JPG

                                           

                                          Part1a.JPG

                                          Part1fSW.JPG

                                          Part1f.JPG

                                  • Re: Glitchy geometry
                                    Jonathan Walp

                                    Hi Andreas,

                                    This looks like you might have a coincident body in SOLIDWORKS that is hidden/suppressed. In Visualize it's brought in with the opacity all the way down to 0, but this causes some artifacts. There are a couple of ways around this:

                                     

                                    1. Delete the bodies from your SOLIDWORKS model before exporting to Visualize

                                    2. Find the bodies after they are imported into Visualize and uncheck the box for "Visible"

                                    • Re: Glitchy geometry
                                      Damir Galic

                                      I am glitching with Andreas