3 Replies Latest reply on Jan 28, 2019 1:08 AM by Gilbert Fuerer

    SolidWorks 2017 access violation attempt to read from memory

    Sander Storm

      Hello,

       

      I recently bought a 2 in 1 tablet PC to use for school and also to have a kinda mobile device that could run SW for drawing at project locations. I installed SW 2017 on it and it worked pretty good at first, I could easilly create parts and medium sized assemblys. But after a windows update SW 2017 keeps crashing when ever I try to edit a part i.e: edit sketch, intersection cut and even when I try to make a 2D drawing form 3D part. When I open SW in openGL mode nothing is wrong and everything works just fine, so this should mean its GPU related. I was hoping that maybe one of the tech guys on the form here could take a look into my problem.

       

      Many many many thanks in advance.

       

      Things I already tried fixing the problem:

       

      -Reinstalling SolidWorks

      -Installing latest intel HD drivers form their site

      -Installing the older intel HD driver from their site

      -Reinstalling Windows 10 (Formatting the drive reinstall form CD)

      -Going from SolidWorks 2017 to 2018

       

      Specs of the PC:

       

      Brand: EVE

      Model: V

      CPU: Intel 7th Gen Core i7-7Y75

      GPU: Intel HD graphics 615

       

      SolidWorks 2017 preformance log:

       

      ; SolidWorks generated log file - do not edit.

      <VERSION> 4</VERSION>

      <PROC_NUM>4 system processor(s)

      <PROC_ARCH>9, 6, 36361

      <OS>Microsoft Windows 10 , 64-bit 10.0  (Build 15063)

      <MACHINE>V

      <SERIAL>

      <INSTALLER>2

      <SPEED_MEM>1608MHz 17094860800 13582356480           0 140702132989952

      <PROCESSOR> 1 "Intel64 Family 6 Model 142 Stepping 9" "GenuineIntel"

      <PROCESSOR> 2 "Intel64 Family 6 Model 142 Stepping 9" "GenuineIntel"

      <PROCESSOR> 3 "Intel64 Family 6 Model 142 Stepping 9" "GenuineIntel"

      <PROCESSOR> 4 "Intel64 Family 6 Model 142 Stepping 9" "GenuineIntel"

      <VERSIONDATESTAMP>25/2017222</VERSIONDATESTAMP>

      <S>

      <ST>1522624432

      <BUILD>SP4.1 SP4.1

      <HOTFIX>None

      <INTERNALSWVERSION>d170811.003

      <EXEDIR>C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS

      <X64> 1 0

      <DPI>192</DPI>

      <SUPPORTS_TOUCH>1</SUPPORTS_TOUCH>

      <TOOLBAR_BUTTONSIZE>0</TOOLBAR_BUTTONSIZE>

      <ADDIN> FeatureWorks:Disabled SldTrans 1.0:Disabled SldUg 1.0:Disabled SOLIDWORKS DXF3D:Disabled SOLIDWORKS HCG:Disabled SOLIDWORKS HSF:Disabled SOLIDWORKS Inventor:Disabled SOLIDWORKS JPEG:Disabled SOLIDWORKS MDT:Disabled SOLIDWORKS Pro/E:Disabled SOLIDWORKS Routing:Disabled SOLIDWORKS SE:Disabled SOLIDWORKS Toolbox:Disabled SOLIDWORKS Toolbox Browser:Disabled SOLIDWORKS Utilities:Disabled SOLIDWORKS Motion:Disabled SOLIDWORKS Simulation:Disabled

      <REALVIEW> 0

      <MSIE>9.11.15063.0

      <LANGUAGE> english,english,1043

      <CMDLINE> 0,0,0,0,0,0,1,0,0,0,0,0,0,1,-1,0,0,0,0,0, 0

      <PKGTYPE> 2

      <FDBK_OP-IN> 0 </FDBK_OP-IN>

      <SWSID> "20180402011346_25.4.1.0001" </SWSID>

      <FVI>CMD:"excel.exe" ATTR:Detected=1 ATTR:PN="Microsoft Office 2016" ATTR:PV="16.0.9126.2116" ATTR:FV="16.0.9126.2116"</FVI>

      <FVI>CMD:"winword.exe" ATTR:Detected=1 ATTR:PN="Microsoft Office 2016" ATTR:PV="16.0.9126.2116" ATTR:FV="16.0.9126.2116"</FVI>

      <FVI>CMD:"outlook.exe" ATTR:Detected=1 ATTR:PN="Microsoft Outlook" ATTR:PV="16.0.9126.2116" ATTR:FV="16.0.9126.2116"</FVI>

      <FVI>CMD:"iexplore.exe" ATTR:Detected=1 ATTR:PN="Internet Explorer" ATTR:PV="11.00.15063.0" ATTR:FV="11.00.15063.0 (WinBuild.160101.0800)"</FVI>

      <SWINSTALL>ATTR:PN="SOLIDWORKS 2017 SP04.1" ATTR:PV="25.141.1" ATTR:MajV=25 ATTR:MinV=141</SWINSTALL>

      <LAST_BOOT_TIME>ATTR:time=04/02/2018 00:14:01 ATTR:GMTOffset=+01:00</LAST_BOOT_TIME>

      <GRAPHICS> CDD V4.01 X2880 Y1920 32 bits 60Hz

      <ON>:Intel

      <OR>:Intel(R) HD Graphics 615

      <OV>:4.5.0 - Build 23.20.16.4973

      <PV>:23.20.16.4973

      <PN>:Intel HD Graphics Drivers for Windows(R)

      <CN>:Intel Corporation

      <FD>:OpenGL(R) Driver for Intel(R) Graphics Accelerator

      <LC>:Copyright (c) 1998-2016 Intel Corporation.

      <FV>:23.20.16.4973

      <COMPUTERSYSTEMINFO>ATTR:Manufacturer=EVE ATTR:Model=Eve V</COMPUTERSYSTEMINFO>

      <VIDEOCONTROLLERINFO>ATTR:AdapterCompatibility=Intel Corporation ATTR:Description=Intel(R) HD Graphics 615 ATTR:DriverVersion=23.20.16.4973 ATTR:PNPDeviceID=PCI\VEN_8086&DEV_591E&SUBSYS_22128086&REV_02\3&11583659&0&10</VIDEOCONTROLLERINFO>

      <AD2> "LOAD_ADDIN" "fworks.dll" "" [0.06] "25.4.1.1" 11 COM.old 1502484086 1

      <AD2> "LOAD_ADDIN" "SwLoaderSw.dll" "" [0.39] "25.4.1.1" 11 COM.old 1502486211 2

      <AD3>CMD:OLD_STYLE_ADDIN_OVERRIDE=0</AD3>

      <AD2> "LOAD_ADDIN" "composersolidworksplug-in.dll" "SOLIDWORKS Composer" [0.97] "7.4.3.1289" 11 COM.new 1496694591 3

      <AD2> "LOAD_ADDIN" "Dsgnchku.dll" "SOLIDWORKS Design Checker" [0.14] "25.4.1.1" 11 COM.new 1502486336 4

      <AD2> "LOAD_ADDIN" "SldForum.DLL" "SOLIDWORKS Forum 2017" [1.11] "25.4.1.1" 11 NET 1502478142 5

      <AD2> "LOAD_ADDIN" "SOLIDWORKSInspection.DLL" "SOLIDWORKS Inspection" [1.06] "2017.4.0.152" 8 NET 1498163056 6

      <UI_ENVIRONMENT>CMD:LOAD ATTR:TYPE=SWSystem ATTR:ID=1</UI_ENVIRONMENT>

      <UI_ICONCOLOR>CMD:LOAD ATTR:TYPE=SWSystem ATTR:ID=0</UI_ICONCOLOR>

      <CD>=4 57616 0

      <AD2> "LOAD_ADDIN" "sldfuncfeat.dll" "sldFuncFeat" [0.55] "25.4.1.1" 11 COM.new 1502491465 7

      <DOC_OPEN> ".SLDPRT" 0, 0, 1, 1, 3, 0

      <EVENT> [EVT_SWITCH_TO_PART]

      <PROCMEM> CMD:DocOpen ATTR:PageFileBytes=382754816 ATTR:PageFileBytesPeak=382754816 ATTR:PoolNonpagedBytes=203624 ATTR:PoolPagedBytes=2860928 ATTR:PrivateBytes=382754816 ATTR:VirtualBytes=36758659072 ATTR:VirtualBytesPeak=36758659072 ATTR:WorkingSet=665272320 ATTR:WorkingSetPeak=665272320 ATTR:AvailableReservesMask=7 ATTR:GDIHandlesTotal=10000 ATTR:GDIHandlesUsed=1162 </PROCMEM>

      <*CD>[13.44]

      <CD>=13 34081 0

      <CD>=8 32888 0

      <*CD>[0.30]

      <MINIDUMP> "23516b26-e617-416b-a37e-4a9ce3dbe0ef" </MINIDUMP>

      <EXCEPTION> "Access Violation at aabf1621 (virtual address 00000040), attempt to read from memory"

      <RESOURCE_WARNING>CMD:GDIHandles ATTR:used=1232 ATTR:load=12.32 ATTR:free=8768 CMD:CommitChargeMB ATTR:used=4167 ATTR:load=21.65 ATTR:free=15079</RESOURCE_WARNING>

      <AD5> auModelView_c::GraphicsRenderPostNotify;auModelView_c::RepaintPostNotify;auAm_c::GetEnableFileMenu;auAm_c::GetEnableFileMenu;auAm_c::GetEnableFileMenu;auModelView_c::RepaintNotify;auAm_c::XDispatch::get_IActiveDoc2;auModelView_c::RenderLayer0Notify;auModelView_c::BufferSwapNotify;

      <RAWSTACK> ig9icd64:AABF1621:00021621,ig9icd64:AAC4E613:0007E613,ig9icd64:AAD2E81C:0015E81C,ig9icd64:AB0A6DD8:004D6DD8,ig9icd64:AACB1AA1:000E1AA1,ig9icd64:AAC5A7EA:0008A7EA,ig9icd64:AABE3D54:00013D54,sldrglu:3313C0D5:0007C0D5,slduiu:480B25DE:007E25DE,sldgraphicsuiu:33290673:00050673,sldgraphicsuiu:332937CC:000537CC,sldgraphicsuiu:3328F243:0004F243,sldgraphicsuiu:3329C406:0005C406,sldprtu:3399E87B:0005E87B,slduiu:47F8FE6F:006BFE6F,mfc110u:E22012CA:002512CA,sldappu:44E4DC44:0013DC44,mfc110u:E2215E72:00265E72,mfc110u:E2215884:00265884,sldappu:44E4E49F:0013E49F,slduiu:47F92DAA:006C2DAA,mfc110u:E221320A:0026320A,mfc110u:E22135C4:002635C4,mfc110u:E20CB995:0011B995,USER32:EFC2BC50:0000BC50,USER32:EFC2B80B:0000B80B,OPENGL32:C8C7911E:0003911E,USER32:EFC2BC50:0000BC50,USER32:EFC2B94C:0000B94C,USER32:EFC41793:00021793,ntdll:F0F390A4:000A90A4,win32u:EDBB1744:00001744;

      <SWEXHONPAINT>

      <SWEXH>

      <MINIDUMP> "0825b934-a10e-40df-ada0-250f221f6a7a" </MINIDUMP>

      <EXCEPTION> "Access Violation at ed5ea1a8 (virtual address 00000040), attempt to read from memory"

      <RESOURCE_WARNING>CMD:GDIHandles ATTR:used=1232 ATTR:load=12.32 ATTR:free=8768 CMD:CommitChargeMB ATTR:used=4336 ATTR:load=22.53 ATTR:free=14910</RESOURCE_WARNING>

      <AD5> auModelView_c::GraphicsRenderPostNotify;auModelView_c::RepaintPostNotify;auAm_c::GetEnableFileMenu;auAm_c::GetEnableFileMenu;auAm_c::GetEnableFileMenu;auModelView_c::RepaintNotify;auAm_c::XDispatch::get_IActiveDoc2;auModelView_c::RenderLayer0Notify;auModelView_c::BufferSwapNotify;

      <RAWSTACK> KERNELBASE:ED5EA1A8:0006A1A8,MSVCR110:E359DE25:0005DE25,ntdll:F0F39603:000A9603,sldappu:44E4DC44:0013DC44,mfc110u:E2215E72:00265E72,mfc110u:E2215884:00265884,sldappu:44E4E49F:0013E49F,slduiu:47F92DAA:006C2DAA,mfc110u:E221320A:0026320A,mfc110u:E22135C4:002635C4,mfc110u:E20CB995:0011B995,USER32:EFC2BC50:0000BC50,USER32:EFC2B80B:0000B80B,OPENGL32:C8C7911E:0003911E,USER32:EFC2BC50:0000BC50,USER32:EFC2B94C:0000B94C,USER32:EFC41793:00021793,ntdll:F0F390A4:000A90A4,win32u:EDBB1744:00001744,USER32:EFC2B652:0000B652,sldworks:40008390:00008390,sldappu:44D5DCAA:0004DCAA,sldappu:44D6E430:0005E430,mfc110u:E222CF4A:0027CF4A,sldworks:4000C6AE:0000C6AE,KERNEL32:F0A72784:00012784,ntdll:F0F00D51:00070D51;

      <UNHANDLED>

      </SWEXH>

      <AD2> "UNLOAD_ADDIN" "BendSequenceSwu.dll" "" [0.00] 0

      <PROCMEM> CMD:AppFinish ATTR:PageFileBytes=689340416 ATTR:PageFileBytesPeak=691150848 ATTR:PoolNonpagedBytes=209880 ATTR:PoolPagedBytes=2961352 ATTR:PrivateBytes=689340416 ATTR:VirtualBytes=37111951360 ATTR:VirtualBytesPeak=37142278144 ATTR:WorkingSet=1041100800 ATTR:WorkingSetPeak=1059762176 ATTR:AvailableReservesMask=7 ATTR:GDIHandlesTotal=10000 ATTR:GDIHandlesUsed=1232 </PROCMEM>

      <MEMORY> 1335733, 1059762176, 1041076224, 3070456, 2959608, 210704, 209744, 689303552, 691150848, 689303552 </MEMORY>

      <FT>1522624491

      <EOSL>0</EOSL>

      <RUNTIME>59</RUNTIME>

      <IDLETIME>0</IDLETIME>

      <AT>

        • Re: SolidWorks 2017 access violation attempt to read from memory
          Leonel Yuan

          I had the same problem. The OpenGL driver is corrupted. ig9icd64.dll is not working properly. Reinstalling graphics driver may not help unless this file is replaced. My fix is to reinstall Windows and keeping personal data and apps.

          • Re: SolidWorks 2017 access violation attempt to read from memory
            Samuel Chan

            I had a similar (if not the same) problem, and found that installing an older graphics driver fixed the problem.

             

            My problem:

            When I sketch anything, Solidworks crashes. I can open a part/assembly, view it from different angles, etc. I can also click the Sketch button. But as soon as I sketch anything, a point a line whatever, Solidworks crashes.

            In the crash log, I notice this:

             

            <EXCEPTION> "Access Violation at a7510b82 (virtual address 00000040), attempt to read from memory"

             

            which leads me to this post, and this (after reading Leonel Yuan's reply):

             

            <RAWSTACK> ig9icd64:A7510B82:00020B82,ig9icd64:A7571213:00081213,ig9icd64:A76A5E8C:001B5E8C......

             

            Yuan's reply directed me to suspect it's the graphics driver's problem.

             

            Background details:

            - Windows 10 64-bit (on both PC)

            - both PC have the same bug

            - Solidworks Education Edition 2016 SP5.0 (on one PC)

            - Solidworks Education Edition 2017 SP4.1 (on another PC)

            - graphics processor: Intel HD Graphics 530 (on both PC)

            - driver version: 23.20.16.4973 (on both PC)

            - uninstall current driver and reinstall driver 23.20.16.4973: problem persists

            - uninstall current driver and install newer driver 24.20.100.6136: problem persists

             

            Solution:

            Uninstall the current graphics driver and install an older graphics driver. Here are the steps:

            1. Download Display Driver Uninstaller (DDU) (I used DDU v17.0.8.6).

            2. Download an older graphics driver. In my case, I downloaded version 21.20.16.4542 from my PC vendor, Dell. (The site you use and the driver version you get may differ depending on your PC brand.)

            3. Run the downloaded DDU exe. It will extract to a folder.

            4. Restart the PC in safe mode.

            5. Open the extracted folder, and run "Display Driver Uninstaller.exe".

            6. Click the "Clean and restart" button. It will uninstall the current graphics driver and restart the PC.

            7. Install the old graphics driver.

            8. Restart the PC. (At this point, Solidworks works for me.)

             

            Hope it helps!

            • Re: SolidWorks 2017 access violation attempt to read from memory
              Gilbert Fuerer

              Thanks for the hint with the faulty graphics driver.
              I just downloaded the latest (Type "QNF", for my Quadro) from nvidia.com and did a "clean installation". All works well, so far!