8 Replies Latest reply on Mar 29, 2018 2:36 PM by Kevin Casey

    Mate tool defaulting to tangent

    Kevin Casey

      I have two components with flat faces that I am trying to mate with Parallel. When I select them SW defaults to the tangent mate.

       

      If I pre-select the Parallel button and select one of the faces I get "Select entity is not valid for current mate type".

       

      Both of the components are imported STEP files.

       

      Never had this problem before, I have performed this task dozens of times with similar components. I just upgraded to SW 2018.

       

      Anyone know what is going on?

        • Re: Mate tool defaulting to tangent
          Lars Lamhauge

          Hi Kevin,

          My spontaneous tip would be to check if SW recognized all your lines in the STP-file as splines. If that is the case it would explain why it defaults to tangent. I have recently imported a lot of dxf and stp files from AutoCAD and all my lines were imported as splines even if they are straight.

          • Re: Mate tool defaulting to tangent
            Thomas Voetmann

            You say "flat faces" and "STEP". Sometimes seemingly flat faces are not flat, and then SW will default to tangent mate.

            One easy way to determine if a face really is flat is to try to create a 2D-sketch on it. If success then that face is flat and vice versa.

            If you discover that the face is not flat (but very close) try "Delete face" - "Delete" (dont try to patch or fill). Create a plane using three vertices - create a sketch - convert entities - Planar surface - Knit (create solid). The Knit will usually compensate small deviations from the plane.

            • Re: Mate tool defaulting to tangent
              Glenn Schroeder

              As Thomas Voetmann said, since it's an imported step file, I suspect the surfaces aren't really flat.  From you describing what was happening I suspected that even before reading that it was step files.  If his suggestions don't work you might try opening the part files and inserting planes tangent to the surfaces, and use these planes for your Assembly mates.

                • Re: Mate tool defaulting to tangent
                  Kevin Casey

                  Thanks guys, I reworked the surfaces and got functionality. Cumbersome process, first time I have encountered this. I just upgraded to SW 2018, do you know if there are import settings that I should adjust? I brushed past talk of that in the blogs but have yet to research further. I get it that computer programming does it's own dance, but flat should be flat.

                    • Re: Mate tool defaulting to tangent
                      Paul Risley

                      I don't know for sure if there is a setting that will fix the issue you found with these parts. While there are settings for importing that can be massaged to get good results there is still the limiting factor of how was the model exported in the first place. Like Glenn Schroeder I suspected imported models from just the title.

                       

                      Depending on the export software you can get spline structure for radii and sometimes seemingly flat surfaces. It sucks there is no doubt about it.

                       

                      Typically I have to analyze every part and assembly I import for geometric errors prior to moving into the tooling phase just for this reason.

                      • Re: Mate tool defaulting to tangent
                        Kristina Smith

                        It could be that whoever created the original file did some funky stuff either during creation or during export (or their program of choice did some funky stuff). Sometimes features get lost in translation between formats. You could try re-exporting the file as different formats (STL, parasolid, etc) and reimporting them to see if things start to play nice, but that would probably be overkill for this, since it was a fairly easy fix apparently.