AnsweredAssumed Answered

Assemblies Cannot Locate Files

Question asked by Dan Riffell on Mar 6, 2018
Latest reply on Oct 10, 2019 by Jacky Hao

I've got a weird one for you, SolidPeeps. I'll try to explain the best I can the issue and what I've done to try to fix it, but I can't promise to keep it PG13.

I am working with SW '17-'18 Student Edition.

When opening any assembly the software is unable to find any components. SW asks me to locate the files every...single...time. If I do not point it directly to every single file they show up as suppressed with an error message attached: Cannot locate the file for the component to complete the operation. If I point the assembly to the files, save the files, save the assembly, and exit, upon reopening I get the same, regardless of complexity of the assembly. (Side question: didn't there used to be a checkbox in Options for the assembly to look in the same folder for missing files?)

I tried messing with the External Reference options to no avail.

I have these files stored on the Documents folder because this gets backed up to my server. So I tried moving an assembly to the Desktop. No bueno.

I tried nuking the registry. No dice.

Called and WebEx'ed my VAR, and I could hear the head-scratching over the phone.

I tried moving an assembly after P&G to the desktop. Same issue.

If I open an assembly from Dropbox I have no problems. That got me thinking. I moved the P&G assembly to a folder I created on the C drive, and it worked just fine.

Can someone explain this sorcery before HR has to forcibly remove me from my office?  

Outcomes