AnsweredAssumed Answered

Sub-Assembly inaccessible

Question asked by Thijs Haverkamp on Mar 5, 2018
Latest reply on Mar 6, 2018 by Thijs Haverkamp

Hi Everybody,

 

Well,.. here we go yet again.

 

 

Quite suddenly (I don't recall making any weird changes but adding a few holes to an allready exisiting sketch) one of my sub-assemblies is inaccessible. It's used twice in the assembly, in different configurations. When trying to open the file it has an empty feature-tree, apart from the configurations. Like it's not resolved, but in light-weight or supressed.

 

When I try and change the configuration I get the following message ''SOLIDWORKS encountered a serious problem in the file %1.''

*Tried opening the sub-assembly separately (without the main-assembly opened)    -Didn't work, assembly still empty.

*Changed the configuration in the sub-assembly then...

 

*Tried openening all parts of the sub-assembly seperately    -All parts open in good order, their configurations work in good order, but still do not show in the sub-assembly.

*Changed the configuration in the sub-assembly then...

 

I'm on a VERY tight deadline, and this has been the so manieth ''bug'' (I presume) and this stuff is costing me a lot of time and thus money.

 

SOLIDWORKS YOU ARE DEPRESSING ME (again)

 

Any thoughts?

 

 

Ive been really careful about external references and any other things that confuses SolidWorks in some situations, I did a lot of extra work making sure all sub-assemblies and parts have their own independent configurations to activate in stead of having to connect references or shared geometry.

Outcomes