8 Replies Latest reply on Mar 1, 2018 2:30 PM by Kevin Chandler

    No drag mode?

    Tom Gagnon

      I'm trying to select carefully placed annotations to edit them, and it's difficult to select each item in sequence without accidentally inducing a tiny click-drag which moves the item unintentionally when I only intended to click it.

       

      Is there a no-drag mode, or a similar option which I can toggle as needed, to only take clicks and not click-drag inputs?

       

      I suppose that I could Lock location of every object that I don't want to move, or add relations to a hidden grid, or such. I'm trying to avoid this tedium, both in setup and breaking the Lock when good composition requires moving it. However, I am perpetuating these drawings across multiple documents to express externally similar assemblies with save_as and replace model, so maybe initial tedium will carry over to future iterations.

       

      Workarounds that I've considered which may approximate what I want, if such a setting does not exist:

      Selection sets that I can lock and unlock as desired? That adds another thing to alter with changes and composition as new annotations may be added.

      Mouse control hackery such as a 3rd party utility which accomplishes an input filter to achieve what I want.

      Hiding everything else to make annotation selections simpler, although it'd be more difficult to edit correctly when I can't see what it's connected to.

        • Re: No drag mode?
          Dan Pihlaja

          Is this at the drawing level or the part/assembly level?

            • Re: No drag mode?
              Tom Gagnon

              Entirely within drawings, expressing a large assembly.

              "No drag mode? in Drawings and Detailing"

              Sorry if context was unclear.

               

              If an assembly, I could select objects from the Design Tree. Annotations in a drawing are not selectable from a list in the tree, that I know of. Even if it was, I doubt it'd be very helpful to pick from, say, Text01, Text02, ... etc.

                • Re: No drag mode?
                  Dan Pihlaja

                  Tom Gagnon wrote:

                   

                  Entirely within drawings, expressing a large assembly.

                  "No drag mode? in Drawings and Detailing"

                  Sorry if context was unclear.

                   

                  If an assembly, I could select objects from the Design Tree. Annotations in a drawing are not selectable from a list in the tree, that I know of. Even if it was, I doubt it'd be very helpful to pick from, say, Text01, Text02, ... etc.

                   

                  Sorry, I missed that it was posted in the drawing and detailing section.  LOL

              • Re: No drag mode?
                Glenn Schroeder

                I'm not sure exactly which annotations you mean, but if it's notes then you can right-click on them (which won't move them) and choose one of these options:

                 

                 

                If it's a dimension that you want to edit or add text, then again right-click.  That will bring up the Property Manager where you can do that without moving the dimension.  Will this work for you, or was there another annotation type you were referring to?

                • Re: No drag mode?
                  Kevin Chandler

                  Hello,

                   

                  If it's note entities you're referring to, then hold down the Ctrl key when you double-click.

                  You'll be put into edit mode if you don't move the mouse too much when you DC and if you do move too much, then a new copy of the note is created instead.

                  You'll have to delete the new copied note if that happens, but at least the original note won't be moved.

                   

                  I hope this helps.

                   

                  Cheers,

                   

                  Kevin

                  • Re: No drag mode?
                    Kevin Chandler

                    Another thought is to adjust your mouse settings in Control Panel to see if a change in DC time would help.

                     

                    Cheers,

                     

                    Kevin