2 Replies Latest reply on Jun 20, 2018 12:38 AM by Brad Huitt

    Installation error 1721 on DraftSight 2018 SP1 x64

    Robert Conklin

      Hi,  I am having this error:

       

      DraftSight 2018 Install Problem.JPG

      Would anyone have an insight?

      Thanks

       

      Edit:

      I solved it by doing a reinstall of Windows 10

      Not that I had to, BUT starting Fresh is Always better for I also wanted to up grade it to SW 2017

      thanks

        • Re: Installation error 1721 on DraftSight 2018 SP1 x64
          Ken Maren

          Disable anti-virus and anti-spyware plus disable UAC for the install.   If that doesn't work, the Windows Installer registration status may be corrupt.   Google re-registering Windows Installer. 

          • Re: Installation error 1721 on DraftSight 2018 SP1 x64
            Brad Huitt

            While this problem seems to be a little different than mine, I wanted to post my solution for those who might still be having trouble and looking for other things to try and fix their Draftsight 2018 problems.

             

            My issue involved Draftsight not being able to install.  It would crash when it tried to register a DLL with regsvr32.

             

            Noneof Yourbussines posted a solution on another thread about installing the 2015 C++ redistributables, but I had both of the VS 2015 C++ redistributables installed already.  Repairing them didn't work either.  After re-evaluating the error message (like Kalle Mikael the error message said it was unable to register a DLL using regsvr32) I deduced that maybe there was a problem with the x86 (32bit) version of the VS 2015 C++ redistributables.  So I

            1. downloaded the VS 2015 C++ Redistributable package from Microsoft download
            2. then I uninstalled the x86 version
            3. rebooted
            4. then re-installed it.

            After that I was able to install Draftsight 2018 SP2 without any problems, as well as some other software that was giving me fits!

             

            Don't forget to disable your anti-virus and right click the installation and run it as administrator.